View Issue Details

IDProjectCategoryView StatusLast Update
0000522OpenFOAM[All Projects] Bugpublic2012-05-15 12:45
Reporteruser422Assigned Tohenry 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Platformx86_64OSDebianOS Version2.6.32-5-amd64
Product Version 
Fixed in Version 
Summary0000522: Dimensions of the rho-field not concidered in MULES
Descriptionwhen volScalarField is used for rho in MULES::implicitSolve, dimensions mismatch error occurs at lines 146-148 in MULESTemplates.C while calculating tmp<surfaceScalarField> Cof.
Steps To ReproduceMULES::implicitSolve(rho1, alpha1, rhoPhi, rhoPhi1, alpha1Sp, alpha1Su, 1, 0);
Additional InformationFor a particular case, I could get rid of the error by Cof division by the dimension of rho:

const dimensionedScalar dimRho("dimRho", rho.dimensions(), 1.0);
        
tmp<surfaceScalarField> Cof =
        mesh.time().deltaT()*mesh.surfaceInterpolation::deltaCoeffs()
       *mag(phi)/mesh.magSf()/dimRho;

But in this case the incompressible way of using MULES doesn't work:
MULES::implicitSolve(geometricOneField(), alpha1, phi, phiAlpha, alpha1Sp, alpha1Su, 1, 0);
because of the error: ‘const class Foam::geometricOneField’ has no member named ‘dimensions’.

So for now I don't know how to combine the both ways to use MULES in one solver.
TagsMULES, multiphase

Activities

user422

2012-04-26 13:38

  ~0001288

Last edited: 2012-04-27 13:16

View 2 revisions

The problem is that Cof has the same dimensions as rho, and CoLambda (line 167 in MULESTemplates.C) is dimless. Unfortunately I don't know the meaning of Cof, so I can't say what exactly is wrong in its calculation.

The only clear thing is that Cof has also to be dimless. Possible solution could be extension of the class geometricOneField by adding geometricOneField.dimensions() and subsequent division of Cof by rho.dimensions(). Or may be a reformulation of Cof is needed, I don't know.

henry

2012-05-15 12:45

manager   ~0001317

Thanks for the bug report.

I have added a bit of templating gymnastics to handle density differently depending on the type so that phi is now scaled by rho if required.

Resolved by commit fcbce1826a654ff890e3fcfaea3b7b4795e073d1

Issue History

Date Modified Username Field Change
2012-04-26 11:45 user422 New Issue
2012-04-26 11:48 user422 Tag Attached: multiphase
2012-04-26 11:48 user422 Tag Attached: MULES
2012-04-26 13:38 user422 Note Added: 0001288
2012-04-27 13:16 user422 Note Edited: 0001288 View Revisions
2012-05-15 12:45 henry Note Added: 0001317
2012-05-15 12:45 henry Status new => resolved
2012-05-15 12:45 henry Resolution open => fixed
2012-05-15 12:45 henry Assigned To => henry