View Issue Details

IDProjectCategoryView StatusLast Update
0000512OpenFOAM[All Projects] Bugpublic2012-04-17 12:22
Reporteruser326Assigned Touser2 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version11.10
Product Version 
Fixed in Version 
Summary0000512: changeDictionary - instance flag problem - #0000511 report follow up
DescriptionThe changeDictionary application with 'instance' flag wont pick up the desired time.

In case of a transient solver like icoFoam it always picks up the very first time step. With the instance flag it picks up the first step plus adds undesired nonuniform values for internalField.

In case of a steady-state solver like simpleFoam it always picks up the latest time step. The instance flag has no other effect.
Steps To Reproducerun Allrun or AllrunPar in the attached cases. Change comment to enable the instance flag.
Additional InformationSorry for my earlier bug report, it was written out of bitter frustration and not enough info was provided. The parallel flag is indeed working, I must have made a mistake in the syntax.
TagsNo tags attached.

Relationships

duplicate of 0000511 closeduser4 changeDictionary - instance flag has no effect, parallel case modification 

Activities

user326

2012-04-17 08:25

 

changeDict.tar.gz (5,457 bytes)

user2

2012-04-17 12:22

  ~0001261

duplicate of #511 (resolved)

Issue History

Date Modified Username Field Change
2012-04-17 08:25 user326 New Issue
2012-04-17 08:25 user326 File Added: changeDict.tar.gz
2012-04-17 12:21 user2 Relationship added duplicate of 0000511
2012-04-17 12:22 user2 Note Added: 0001261
2012-04-17 12:22 user2 Status new => resolved
2012-04-17 12:22 user2 Resolution open => fixed
2012-04-17 12:22 user2 Assigned To => user2