View Issue Details

IDProjectCategoryView StatusLast Update
0000051OpenFOAM[All Projects] Bugpublic2010-10-14 10:58
Reporteruser35Assigned Tohenry 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformLinuxOSOpenSuseOS Version11.3
Product Version 
Fixed in Version 
Summary0000051: code crashing when using interDyMFoam in parallel
DescriptionI performed a simulation of a bubble steadily moving in a rectangular straight channel by using interDyMFoam. I ran the case in parallel with two processors to study how interDyMFoam works with my problem. However, it seems the code always crashes after some time steps. Attached I send you the case and error file. To be assure, the error is

[1] #0 Foam::error::printStack(Foam::Ostream&) in "/fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libOpenFOAM.so"
[1] #1 Foam::sigFpe::sigFpeHandler(int) in "/fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libOpenFOAM.so"
[1] #2 ?? in "/lib64/libc.so.6"
[1] #3 Foam::GAMGSolver::scalingFactor(Foam::Field<double>&, Foam::Field<double> const&, Foam::Field<double> const&, Foam::Field<double> const&) const in "/fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libOpenFOAM.so"
[1] #4 Foam::GAMGSolver::scalingFactor(Foam::Field<double>&, Foam::lduMatrix const&, Foam::Field<double>&, Foam::FieldField<Foam::Field, double> const&, Foam::UPtrList<Foam::lduInterfaceField const> const&, Foam::Field<double> const&, unsigned char) const in "/fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libOpenFOAM.so"
[1] #5 Foam::GAMGSolver::Vcycle(Foam::PtrList<Foam::lduMatrix::smoother> const&, Foam::Field<double>&, Foam::Field<double> const&, Foam::Field<double>&, Foam::Field<double>&, Foam::Field<double>&, Foam::PtrList<Foam::Field<double> >&, Foam::PtrList<Foam::Field<double> >&, unsigned char) const in "/fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libOpenFOAM.so"
[1] #6 Foam::GAMGSolver::solve(Foam::Field<double>&, Foam::Field<double> const&, unsigned char) const in "/fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libOpenFOAM.so"
[1] #7 Foam::fvMatrix<double>::solve(Foam::dictionary const&) in "/fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libfiniteVolume.so"
[1] #8 main in "/fhome/hoang/OpenFOAM/OpenFOAM-1.6/applications/bin/linux64GccDPOpt/interDyMFoam"
[1] #9 __libc_start_main in "/lib64/libc.so.6"
[1] #10 _start at /usr/src/packages/BUILD/glibc-2.9/csu/../sysdeps/x86_64/elf/start.S:116
[node20:19972] *** Process received signal ***
[node20:19972] Signal: Floating point exception (8)
[node20:19972] Signal code: (-6)
[node20:19972] Failing at address: 0x43200004e04
[node20:19972] [ 0] /lib64/libc.so.6 [0x2ab105a306e0]
[node20:19972] [ 1] /lib64/libc.so.6(gsignal+0x35) [0x2ab105a30645]
[node20:19972] [ 2] /lib64/libc.so.6 [0x2ab105a306e0]
[node20:19972] [ 3] /fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libOpenFOAM.so(_ZNK4Foam10GAMGSolver13scalingFactorERNS_5FieldIdEERKS2_S5_S5_+0x69) [0x2ab104bef919]
[node20:19972] [ 4] /fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libOpenFOAM.so(_ZNK4Foam10GAMGSolver13scalingFactorERNS_5FieldIdEERKNS_9lduMatrixES3_RKNS_10FieldFieldIS1_dEERKNS_8UPtrListIKNS_17lduInterfaceFieldEEERKS2_h+0xaa) [0x2ab104befd2a]
[node20:19972] [ 5] /fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libOpenFOAM.so(_ZNK4Foam10GAMGSolver6VcycleERKNS_7PtrListINS_9lduMatrix8smootherEEERNS_5FieldIdEERKS8_S9_S9_S9_RNS1_IS8_EESD_h+0x1752) [0x2ab104bf2ff2]
[node20:19972] [ 6] /fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libOpenFOAM.so(_ZNK4Foam10GAMGSolver5solveERNS_5FieldIdEERKS2_h+0x46f) [0x2ab104bf3d1f]
[node20:19972] [ 7] /fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libfiniteVolume.so(_ZN4Foam8fvMatrixIdE5solveERKNS_10dictionaryE+0x158) [0x2ab1035bb498]
[node20:19972] [ 8] interDyMFoam [0x425519]
[node20:19972] [ 9] /lib64/libc.so.6(__libc_start_main+0xe6) [0x2ab105a1c586]
[node20:19972] [10] interDyMFoam [0x41f8c9]
[node20:19972] *** End of error message ***
--------------------------------------------------------------------------
mpiexec noticed that process rank 1 with PID 19972 on node node20 exited on signal 8 (Floating point exception).
--------------------------------------------------------------------------
Additional Information[1] #0 Foam::error::printStack(Foam::Ostream&) in "/fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libOpenFOAM.so"
[1] #1 Foam::sigFpe::sigFpeHandler(int) in "/fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libOpenFOAM.so"
[1] #2 ?? in "/lib64/libc.so.6"
[1] #3 Foam::GAMGSolver::scalingFactor(Foam::Field<double>&, Foam::Field<double> const&, Foam::Field<double> const&, Foam::Field<double> const&) const in "/fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libOpenFOAM.so"
[1] #4 Foam::GAMGSolver::scalingFactor(Foam::Field<double>&, Foam::lduMatrix const&, Foam::Field<double>&, Foam::FieldField<Foam::Field, double> const&, Foam::UPtrList<Foam::lduInterfaceField const> const&, Foam::Field<double> const&, unsigned char) const in "/fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libOpenFOAM.so"
[1] #5 Foam::GAMGSolver::Vcycle(Foam::PtrList<Foam::lduMatrix::smoother> const&, Foam::Field<double>&, Foam::Field<double> const&, Foam::Field<double>&, Foam::Field<double>&, Foam::Field<double>&, Foam::PtrList<Foam::Field<double> >&, Foam::PtrList<Foam::Field<double> >&, unsigned char) const in "/fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libOpenFOAM.so"
[1] #6 Foam::GAMGSolver::solve(Foam::Field<double>&, Foam::Field<double> const&, unsigned char) const in "/fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libOpenFOAM.so"
[1] #7 Foam::fvMatrix<double>::solve(Foam::dictionary const&) in "/fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libfiniteVolume.so"
[1] #8 main in "/fhome/hoang/OpenFOAM/OpenFOAM-1.6/applications/bin/linux64GccDPOpt/interDyMFoam"
[1] #9 __libc_start_main in "/lib64/libc.so.6"
[1] #10 _start at /usr/src/packages/BUILD/glibc-2.9/csu/../sysdeps/x86_64/elf/start.S:116
[node20:19972] *** Process received signal ***
[node20:19972] Signal: Floating point exception (8)
[node20:19972] Signal code: (-6)
[node20:19972] Failing at address: 0x43200004e04
[node20:19972] [ 0] /lib64/libc.so.6 [0x2ab105a306e0]
[node20:19972] [ 1] /lib64/libc.so.6(gsignal+0x35) [0x2ab105a30645]
[node20:19972] [ 2] /lib64/libc.so.6 [0x2ab105a306e0]
[node20:19972] [ 3] /fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libOpenFOAM.so(_ZNK4Foam10GAMGSolver13scalingFactorERNS_5FieldIdEERKS2_S5_S5_+0x69) [0x2ab104bef919]
[node20:19972] [ 4] /fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libOpenFOAM.so(_ZNK4Foam10GAMGSolver13scalingFactorERNS_5FieldIdEERKNS_9lduMatrixES3_RKNS_10FieldFieldIS1_dEERKNS_8UPtrListIKNS_17lduInterfaceFieldEEERKS2_h+0xaa) [0x2ab104befd2a]
[node20:19972] [ 5] /fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libOpenFOAM.so(_ZNK4Foam10GAMGSolver6VcycleERKNS_7PtrListINS_9lduMatrix8smootherEEERNS_5FieldIdEERKS8_S9_S9_S9_RNS1_IS8_EESD_h+0x1752) [0x2ab104bf2ff2]
[node20:19972] [ 6] /fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libOpenFOAM.so(_ZNK4Foam10GAMGSolver5solveERNS_5FieldIdEERKS2_h+0x46f) [0x2ab104bf3d1f]
[node20:19972] [ 7] /fhome/hoang/OpenFOAM/OpenFOAM-1.6/lib/linux64GccDPOpt/libfiniteVolume.so(_ZN4Foam8fvMatrixIdE5solveERKNS_10dictionaryE+0x158) [0x2ab1035bb498]
[node20:19972] [ 8] interDyMFoam [0x425519]
[node20:19972] [ 9] /lib64/libc.so.6(__libc_start_main+0xe6) [0x2ab105a1c586]
[node20:19972] [10] interDyMFoam [0x41f8c9]
[node20:19972] *** End of error message ***
--------------------------------------------------------------------------
mpiexec noticed that process rank 1 with PID 19972 on node node20 exited on signal 8 (Floating point exception).
--------------------------------------------------------------------------
TagsSolver

Activities

user35

2010-10-01 16:08

 

dynamic_refine.tar (532,480 bytes)

henry

2010-10-01 16:11

manager   ~0000059

Could you try running the same case with OpenFOAM-1.7.x?

user35

2010-10-01 16:13

  ~0000060

I will do that and give you feedback next week. Thanks

user35

2010-10-06 20:01

 

serial_report.tar (20,480 bytes)

user35

2010-10-06 20:01

 

parallel_report.tar (20,480 bytes)

user35

2010-10-06 20:11

  ~0000075

Hi Henry,

I did run the same case with OF-1.7.x and got the same error. I did run the case in both parallel and serial and they were crashed after some iterations. It seems that the value of alpha goes over 1 in both case although I set maxAlphaCo equals 0.6. Might be this is the reason make the case crashed since there is "[node20:19972] Signal: Floating point exception (8)" in log file.

I am trying with maxAlphaCo = 0.2. Btw, I uploaded the error logs file in both serial and parallel cases in case you want to check.

Regards,

Duong

henry

2010-10-06 20:59

manager   ~0000076

Your pressure BCs are not correct, compare with tutorial cases.
To run with a Co of 0.6 you should do 3 or maybe 4 alpha sub-cycles.

Issue History

Date Modified Username Field Change
2010-10-01 16:08 user35 New Issue
2010-10-01 16:08 user35 File Added: dynamic_refine.tar
2010-10-01 16:11 henry Note Added: 0000059
2010-10-01 16:11 henry Assigned To => henry
2010-10-01 16:11 henry Status new => feedback
2010-10-01 16:13 user35 Note Added: 0000060
2010-10-01 16:13 user35 Status feedback => assigned
2010-10-06 20:01 user35 File Added: serial_report.tar
2010-10-06 20:01 user35 File Added: parallel_report.tar
2010-10-06 20:11 user35 Note Added: 0000075
2010-10-06 20:59 henry Note Added: 0000076
2010-10-06 21:00 henry Status assigned => resolved
2010-10-06 21:00 henry Resolution open => no change required
2010-10-07 17:59 user2 Tag Attached: Solver