View Issue Details

IDProjectCategoryView StatusLast Update
0000476OpenFOAM[All Projects] Bugpublic2017-04-26 15:49
Reporteruser397Assigned Touser2 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version 
Fixed in Version 
Summary0000476: tutorial running failure
DescriptionHi, when I run the oscillating Box tutorial from Oscillating box example - $FOAM_TUTORIALS/incompressible/potentialFreeSurfaceFoam/oscillatingBox, after blockMesh, I run checkMesh for checking the mesh, and then there's an error msg:
Oscillating box example - $FOAM_TUTORIALS/incompressible/potentialFreeSurfaceFoam/oscillatingBox.
And when I tried to run "potentialFreeSurfaceFoam" the error msg appeared:
Create mesh for time = 0


PIMPLE: Operating solver in PISO mode

Reading field p (kinematic)



--> FOAM FATAL IO ERROR:
cannot find file

file: /home/kyang/OpenFOAM/OpenFOAM-2.1.0/tutorials/incompressible/potentialFreeSurfaceFoam/oscillatingBox/0/p at line 0.

    From function regIOobject::readStream()
    in file db/regIOobject/regIOobjectRead.C at line 73.

FOAM exiting
Steps To ReproduceI have tried it several times and the same problem happened each time.
TagsNo tags attached.

Activities

user397

2012-03-21 09:09

  ~0001155

Hi all
I have understood now that this is not a bug. The thing is when running the tutorial just use ./Allrun
Only blockMesh and run is not enough.

Sorry for any spam. Please list this as solved. Thank you!

user2

2012-03-21 09:10

  ~0001156

This tutorial performs a number of steps prior to running the solver, and should be run using the Allrun script provided, i.e.:

blockMesh
topoSet
subsetMesh -overwrite c0 -patch floatingObject
cp -r 0.org 0 > /dev/null 2>&1
potentialFreeSurfaceFoam

Issue History

Date Modified Username Field Change
2012-03-21 08:04 user397 New Issue
2012-03-21 09:09 user397 Note Added: 0001155
2012-03-21 09:10 user2 Note Added: 0001156
2012-03-21 09:10 user2 Status new => resolved
2012-03-21 09:10 user2 Fixed in Version => 2.1.x
2012-03-21 09:10 user2 Resolution open => no change required
2012-03-21 09:10 user2 Assigned To => user2