View Issue Details

IDProjectCategoryView StatusLast Update
0000416OpenFOAM[All Projects] Bugpublic2015-02-01 16:33
Reporteruser203Assigned Tohenry 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version10.04
Product Version 
Fixed in Version 
Summary0000416: Using transformPoints or rotateMesh to rotate a mesh by 180 degrees about Z axis fails.
DescriptionWhenever one uses rotateMesh or transformPoints -rotate to rotate about Z by 180 degrees, the mesh ends up being rotated 180 degrees about X. It looks like there's a bug in how the rotation matrix is created. If one does the rotation in two steps of 90 degrees, the rotation works fine.
Steps To ReproduceUse rotateMesh or transformPoints -rotate on any mesh and set the rotation to be 180 degrees.
TagsNo tags attached.

Activities

henry

2015-02-01 16:33

manager   ~0003641

Resolved by commit dae8d838232725781dc2fea44c1852bd5d142ea0

Issue History

Date Modified Username Field Change
2012-02-08 16:24 user203 New Issue
2015-02-01 16:33 henry Note Added: 0003641
2015-02-01 16:33 henry Status new => resolved
2015-02-01 16:33 henry Resolution open => fixed
2015-02-01 16:33 henry Assigned To => henry