View Issue Details

IDProjectCategoryView StatusLast Update
0003961OpenFOAMBugpublic2024-06-18 08:26
ReporterZoeSydney Assigned Tochris  
Status closedResolutionfixed 
PlatformDocker desktop 4.17.0 released oOSmacOS MontereyOS Version12.6.3
Product Version10 
Summary0003961: Cannot launch openfoam10-macos after installation
DescriptionHi there

I have been trying to install &launch openfoam on my laptop for a week. But it seems that something is preventing openfoam10-macos from being launched.
Details for the installation:
Macbook Pro: macOS Monterey 12.6.3; Memory: 16 GB 1867 MHz DDR3
Docker Desktop 4.17.0 released on 2023-02-27;
XQuartz 2.8.5 2023-01-26

I have tried troubleshooting myself but still need help figuring out the problem. I ensured the docker was running in the background when I launched openfoam.
I've attached several screenshots. One of them shows that "No directory exists" when I tried to launch openfoam. I'm sure there is a folder named "openfoam" in /Users/Zoo, and Xquartz can recognize the folder.

TagsNo tags attached.



2023-03-04 23:48


Chris Barton

2023-06-20 15:34

reporter   ~0013053

I also had this problem and was able to get it to work by modifying the file openfoam10-macos from
I'll attache my modified file below. I called the file openfoam10-macos when I was using it, but uploaded it here as openfoam10-macos_modified for clarity.
it's not greatly coded (I've never used docker before) but worked for me... I may have accidentally broken some other functionality so it's probably worth having someone who knows things to have a look at the changes.
And there are some unnecessary 'echos' I used to figure out what the variable values were which can be removed.
I hope this helps.
openfoam10-macos_modified (6,914 bytes)   
# =========                 |
# \\      /  F ield         | OpenFOAM: The Open Source CFD Toolbox
#  \\    /   O peration     |
#   \\  /    A nd           | Copyright (C) 2017-2023 OpenFOAM Foundation
#    \\/     M anipulation  |
# License
#     This program is free software: you can redistribute it and/or modify it
#     under the terms of the GNU General Public License as published by
#     the Free Software Foundation, either version 3 of the License, or
#     (at your option) any later version.
#     This program is distributed in the hope that it will be useful, but
#     WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
#     or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License
#     for more details.
#     You should have received a copy of the GNU General Public License
#     along with OpenFOAM.  If not, see <>.
# Script
#     openfoam10-macos
# Description
#     Run script for an OpenFOAM 10 Docker image at:

usage () {
    exec 1>&2
    while [ "$#" -ge 1 ]; do echo "$1"; shift; done
    cat <<USAGE

Usage: ${0##*/} [OPTIONS]
  -d | -dir             host directory mounted (defaults to current directory)
  -h | -help            help
  -p | -paraview [vers] include paraview, with version 56 | 510 (default)      
  -u | -upgrade         install latest upgrades to the Docker image
  -x | -xhost           use custom X authority and give container host network

Launches the OpenFOAM-$ver Docker image.
- Requires installation of docker-engine.
- Runs a "containerized" bash shell environment where the user can run OpenFOAM
  and, optionally, ParaView (see below).
- The container mounts the user's file system so that case files are stored
  permanently.  The container mounts the current directory by default, but the
  user can also specify a particular directory using the "-d" option.
- Mounting the user's HOME directory is disallowed.
- The '-xhost' option is useful when accessing the host via 'ssh -X'.
  This option should only be used when strictly necessary, as it relies on the
  option '--net=host' when launching the container in Docker, which will
  give to the container full access to the Docker host network stack and
  potentially the host's system services that rely on network communication,
  making it potentially insecure.

Graphical applications from the Docker container require installation of the
Xquartz X server to display on the host machine.  While applications such as
Gedit, Emacs and GnuPlot will run effectively using Xquartz, more intensive
OpenGL applications, in particular ParaView, can be prohibitively slow.

Therefore, the default Docker image does not contain ParaView and users can
instead install ParaView directly from the vendor and use the built-in reader
module for OpenFOAM:

However, if the user wishes to include ParaView with the official OpenFOAM
reader module in their Docker container, they can do so with the "-p" option.

To store data in $HOME/OpenFOAM/$USER-$ver, the user can launch
$Script either by:
    cd $HOME/OpenFOAM/$USER-$ver && $Script
    $Script -d $HOME/OpenFOAM/$USER-$ver

Further Information:$ver-macos

The container user name appears as "openfoam" but it is just an alias.

    exit 1


while [ "$#" -gt 0 ]
   case "$1" in
   -d | -dir)
       [ "$#" -ge 2 ] || usage "'$1' option requires an argument"
       shift 2
   -h | -help)
   -p | -paraview)
       # No version specified
       { [ "$#" -eq 1 ] || [ "$(echo "$2" | cut -c1)" = "-" ] ; } && \
           paraview_vers=510 && \
	   shift 1 && \
       # Version specified
       case "$paraview_vers" in
           56|510) ;;
           *) usage "'$2' is not a valid ParaView version." \
		    "Valid versions are 56 | 510."
       shift 2
   -u | -upgrade)
   -x | -xhost)
       usage "Invalid option '$1'"

[ "$paraview_vers" ] && \
    echo "Including ParaView $paraview_vers" && \

[ -d "$mount_dir" ] || usage "No directory exists: $mount_dir"
mount_dir=$(cd "$mount_dir" && pwd -P)

[ "$mount_dir" = "$(cd "$HOME" && pwd -P)" ] && \
    usage "Mount directory cannot be the user's home directory" \
          "Make a subdirectory and run from there, e.g." \
          "    mkdir -p $HOME/OpenFOAM/$(whoami)-$ver" \
          "    $Script -d $HOME/OpenFOAM/$(whoami)-$ver"

if [ -n "$custom_xauth" ]
    touch "$xauth_path"

    # Generate a custom X-authority file that allows any hostname
    xauth nlist "$DISPLAY" |  sed -e 's/^..../ffff/' | \
        xauth -f "$xauth_path" nmerge -

    docker_options="-e XAUTHORITY=$xauth_path
                    -v $xauth_path:$xauth_path

user_id=$(id -u 2> /dev/null)
[ -n "$user_id" ] || usage "Cannot determine current user ID"
group_id=$(id -g)


echo "Launching $0"
echo "User: \"$(id -un)\" (ID $user_id, group ID $group_id)"

ifaces=$(ifconfig | grep ^en | cut -d: -f1)
[ "$ifaces" ] || \
    usage "Cannot find a network interface for DISPLAY with ifconfig" \
          "Please report an issue at" \
          "    providing the output of the command: ifconfig"

for i in $ifaces
    ip=$(ifconfig "$i" | grep inet | awk '$1=="inet" {print $2}')
    [ "$ip" ] && break

[ "$ip" ] || \
    usage "Cannot find a network IP for DISPLAY with ifconfig" \
          "Please report an issue at" \
          "    providing the output of the command: ifconfig"

xhost + "$ip"

[ "$upgrade" ] && docker pull "$docker_image"

# shellcheck disable=SC2086
echo "-e Display:" $ip:0 \
echo "-u:" "$user_id":"$group_id" \
echo "-v:" "$mount_dir":$home_dir \
echo "docker_options:" $docker_options \
echo "docker_image:" $docker_image

docker run -it \
    --rm \
    -e DISPLAY=$ip:0 \
    -u "$user_id":"$group_id" \
    -v /tmp/.X11-unix:/tmp/.X11-unix \
    -v "$mount_dir":$home_dir \
   $docker_options \

[ -n "$custom_xauth" ] && [-a -e "$xauth_path" ] && rm "$xauth_path"
openfoam10-macos_modified (6,914 bytes)   


2024-06-18 08:26

manager   ~0013275

I think this is fixed by corrections to the openfoam11-macos, openfoam10-macos and openfoam-dev-macos scripts.

Issue History

Date Modified Username Field Change
2023-03-04 23:48 ZoeSydney New Issue
2023-03-04 23:48 ZoeSydney File Added: Screen Shot 2023-03-05 at 10.26.10 am.png
2023-03-04 23:48 ZoeSydney File Added: Screen Shot 2023-03-05 at 10.24.50 am.png
2023-03-04 23:48 ZoeSydney File Added: Screen Shot 2023-03-05 at 10.22.48 am.png
2023-03-04 23:48 ZoeSydney File Added: Screen Shot 2023-03-05 at 10.19.40 am.png
2023-03-04 23:48 ZoeSydney File Added: Screen Shot 2023-03-05 at 10.18.03 am.png
2023-06-20 15:34 Chris Barton Note Added: 0013053
2023-06-20 15:34 Chris Barton File Added: openfoam10-macos_modified
2024-06-18 08:26 chris Assigned To => chris
2024-06-18 08:26 chris Status new => closed
2024-06-18 08:26 chris Resolution open => fixed
2024-06-18 08:26 chris Note Added: 0013275