View Issue Details

IDProjectCategoryView StatusLast Update
0003893OpenFOAMBugpublic2022-12-06 12:15
ReporterHosseinHavasi Assigned Tochris  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Summary0003893: OpenFoam Installation
DescriptionI installed the openfoam 10 on a VirtualBox and Ubuntu 18.04.
When I run the block mesh command, I see that version 4 is installed.
My system config:
Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz, 2001 Mhz, 4 Core(s), 8 Logical Processor(s), RAM 6
Can anyone help me about this problem ?

TagsNo tags attached.



2022-09-26 16:44

reporter   ~0012758

You installed the openfoam package provided by ubuntu which is openfoam 4.0.
Follow this guide to properly install version 10 provided by Openfoam Foundation:


2022-10-04 10:11

reporter   ~0012759

it seems not a bug because the command 'sudo aptget install openfoam':
- in Ubuntu bionic 18.04LTS will install OpenFOAM 4.1;
- in Ubuntu focal 20.04LTS will install OpenFOAMⓇ 1906.191111;
- in Ubuntu jammy 22.04LTS OpenFOAMⓇ (1912.200626-1);
both on virtual machine and WSL and real hardware.

So to install a system OpenFOAM 10, first I had to add the Fondation repository to apt package management tool, as suggested in the previous note by Tiberias_, and than I can find the package 'openfoam10' among the packages available for installation, e.g. with the command 'sudo aptget install openfoam10'.


2022-12-06 12:15

manager   ~0012910

Appears to be resolved.

Issue History

Date Modified Username Field Change
2022-09-25 12:39 HosseinHavasi New Issue
2022-09-26 16:44 Tiberias_ Note Added: 0012758
2022-10-04 10:11 lorenzotrevisan Note Added: 0012759
2022-12-06 12:15 chris Assigned To => chris
2022-12-06 12:15 chris Status new => closed
2022-12-06 12:15 chris Resolution open => fixed
2022-12-06 12:15 chris Note Added: 0012910