View Issue Details

IDProjectCategoryView StatusLast Update
0003812OpenFOAMBugpublic2022-03-04 18:38
ReporterahessAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSCentOSOS Version8
Product Versiondev 
Fixed in Versiondev 
Summary0003812: Refinement history lost after redistribution preventing unrefining.
DescriptionUse of a distributor causes a break in the refinement history leading to over refinement of the mesh. Tests using the refiner+distributor to refine a moving interface in interFoam develop patches of refined mesh that do not unrefine even though the criterion specifies they are eligible to and their cell levels are reported correctly. This only occurs when a distributor is used and appears near processor boundaries, possibly implying that the splitCells are not being transferred. This occurs with and without the refinementHistory constraint. When modeling moving interfaces such as droplets with high levels of refinement and frequent redistribution this blocks most unrefinement and causes the mesh size to blow up.

I wasn't sure if this was due to the incomplete nature of the feature or an oversight so I am presenting it here.
Steps To ReproduceRun with a distributor and a refiner that is refining a feature that is non-stationary.

I've modified the interFoam/capillaryRise to demonstrate the effects when run in parallel.
TagsNo tags attached.

Activities

ahess

2022-03-02 21:50

reporter  

capillaryRise.zip (586,159 bytes)

henry

2022-03-04 18:38

manager   ~0012508

Resolved by commit 16788ffc368863576a01ef776fd2419cdf532f9f

Issue History

Date Modified Username Field Change
2022-03-02 21:50 ahess New Issue
2022-03-02 21:50 ahess File Added: capillaryRise.zip
2022-03-02 21:50 ahess File Added: capillaryRise_unrefineable_cells.png
2022-03-04 18:38 henry Assigned To => henry
2022-03-04 18:38 henry Status new => resolved
2022-03-04 18:38 henry Resolution open => fixed
2022-03-04 18:38 henry Fixed in Version => dev
2022-03-04 18:38 henry Note Added: 0012508