View Issue Details

IDProjectCategoryView StatusLast Update
0003787OpenFOAMBugpublic2022-01-20 15:39
ReporterwyldckatAssigned Tohenry 
PrioritylowSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Versiondev 
Fixed in Versiondev 
Summary0003787: 'lnInclude' for 'solidSpecie' is not updated automatically
DescriptionThis is a somewhat rare issue, given that it's rare to have folders without a 'Make' folder that are common to several other libraries and need the 'lnInclude' folder.

In the folder 'src/thermophysicalModels', if we update the symbolic link folders, it does not process the folder 'solidSpecie', e.g.:

  src
  cd thermophysicalModels
  wmakeLnIncludeAll -update
  wmakeLnIncludeAll: running wmakeLnInclude
      searching . for 'Make' directories
  wmakeLnInclude: linking include files to ./basic/lnInclude
  wmakeLnInclude: linking include files to ./chemistryModel/lnInclude
  wmakeLnInclude: linking include files to ./reactionThermo/lnInclude
  wmakeLnInclude: linking include files to ./laminarFlameSpeed/lnInclude
  wmakeLnInclude: linking include files to ./thermophysicalProperties/lnInclude
  wmakeLnInclude: linking include files to ./barotropicCompressibilityModel/lnInclude
  wmakeLnInclude: linking include files to ./solidThermo/lnInclude
  wmakeLnInclude: linking include files to ./specie/lnInclude

The simplest fix would be to add this line to 'src/thermophysicalModels/Allwmake':

   wmakeLnInclude -update solidSpecie

before all other 'wmake' calls.

Other alternatives I can think of:
1- Either would require to either create a dummy library folder 'Make' with 'LIB=' inside it, at the risk of breaking something else.
2- Upgrading 'wmakeLnIncludeAll' to account for these special kinds of shared folders.
3- Have a new kind of template/header library, e.g. 'Make/files' with just a marker keyword 'INCLIB', mostly just to allow us to have a simple update to 'wmakeLnIncludeAll'.

Steps To ReproduceRunning these commands will reproduce the issue:

  src
  cd thermophysicalModels
  rm solidSpecie/lnInclude/tabulatedSolidTransport*
  wclean solidThermo
  ./Allwmake -update

Results in something like this:
  ..../OpenFOAM/OpenFOAM-dev/src/thermophysicalModels/solidSpecie/lnInclude/forSolids.H:44:10: fatal error: tabulatedSolidTransport.H: No such file or directory
   #include "tabulatedSolidTransport.H"
            ^~~~~~~~~~~~~~~~~~~~~~~~~~~
  compilation terminated.

This was because 'tabulatedSolidTransport*' files were not added in the first commit, along with when 'solidSpecie' was introduced.
TagsNo tags attached.

Activities

henry

2022-01-20 14:15

manager   ~0012416

Try with

src
cd thermophysicalModels
rm solidSpecie/lnInclude/tabulatedSolidTransport*
wclean solidThermo
wcleanLnIncludeAll
./Allwmake -update

We find that Allwmake -update is not entirely reliable and sometimes does not update the lnInclude directories or .dep files correctly and manual intervention is needed.

henry

2022-01-20 14:33

manager   ~0012418

> 1- Either would require to either create a dummy library folder 'Make' with 'LIB=' inside it, at the risk of breaking something else.

Have you tried this?

henry

2022-01-20 15:39

manager   ~0012419

Resolved by commit db45df2e6e7c57d4903bd30f978485edfb537b22

Issue History

Date Modified Username Field Change
2022-01-20 12:13 wyldckat New Issue
2022-01-20 12:13 wyldckat Status new => assigned
2022-01-20 12:13 wyldckat Assigned To => henry
2022-01-20 14:15 henry Note Added: 0012416
2022-01-20 14:33 henry Note Added: 0012418
2022-01-20 15:39 henry Status assigned => resolved
2022-01-20 15:39 henry Resolution open => fixed
2022-01-20 15:39 henry Fixed in Version => dev
2022-01-20 15:39 henry Note Added: 0012419