View Issue Details

IDProjectCategoryView StatusLast Update
0003769OpenFOAMBugpublic2021-12-27 23:27
ReporterjheylmunAssigned Tohenry 
PrioritylowSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSOtherOS Version(please specify)
Product Version9 
Fixed in Versiondev 
Summary0003769: CellCuts constructor with List<plane> cannot be used
DescriptionBecause the plane class does not have a null constructor, it is not possible to create a list of planes for construction of the cellCuts class.
TagsNo tags attached.

Activities

henry

2021-12-27 23:08

manager   ~0012344

Use PtrList for classes without a null constructor

jheylmun

2021-12-27 23:14

reporter   ~0012346

The cellCuts explicitly specifies a List so a PtrList cannot be used currently.

henry

2021-12-27 23:18

manager   ~0012347

> CellCuts constructor with List<plane> cannot be used

Where is this needed in OpenFOAM? In what way is this a bug? I am unable to reproduce the problem, OpenFOAM-9 and OpenFOAM-dev compile fine without any error in CellCuts.

jheylmun

2021-12-27 23:23

reporter   ~0012348

I know it is not necessary for any current implementations, however I was looking to use it for additional development where cutting by planes is preferred.

henry

2021-12-27 23:27

manager   ~0012349

Resolved by commit d1d7963cf84c775c44ae1200d1393b95f961bd4f

Issue History

Date Modified Username Field Change
2021-12-27 22:07 jheylmun New Issue
2021-12-27 23:08 henry Note Added: 0012344
2021-12-27 23:14 jheylmun Note Added: 0012346
2021-12-27 23:18 henry Note Added: 0012347
2021-12-27 23:23 jheylmun Note Added: 0012348
2021-12-27 23:27 henry Assigned To => henry
2021-12-27 23:27 henry Status new => resolved
2021-12-27 23:27 henry Resolution open => fixed
2021-12-27 23:27 henry Fixed in Version => dev
2021-12-27 23:27 henry Note Added: 0012349