View Issue Details

IDProjectCategoryView StatusLast Update
0003760OpenFOAMBugpublic2021-12-07 17:18
ReportercgoessniAssigned Tohenry 
PrioritylowSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Platformamd64OSDebianOS Versionstable
Product Version9 
Fixed in Versiondev 
Summary0003760: valveBank.h does not compile due to a syntax error
DescriptionIn engine/engineValve/valveBank.H, there is a syntax error that makes any code that includes that header fail to compile.

The issue is still present in -dev on lines 58-60
https://github.com/OpenFOAM/OpenFOAM-dev/blob/master/src/fvMeshMovers/engine/engineValve/valveBank.H#L68
Steps To ReproduceTry to include valveBank.H
Additional Informationfix in https://github.com/OpenFOAM/OpenFOAM-dev/pull/38 for -dev
TagsNo tags attached.

Activities

cgoessni

2021-12-07 17:06

reporter   ~0012292

Correction: The error is in lines 68-70 of course.

henry

2021-12-07 17:18

manager   ~0012293

Resolved by commit 25b60616ac3c64abb269e6a40e632fa4b8c7a83f

Issue History

Date Modified Username Field Change
2021-12-07 17:03 cgoessni New Issue
2021-12-07 17:06 cgoessni Note Added: 0012292
2021-12-07 17:18 henry Assigned To => henry
2021-12-07 17:18 henry Status new => resolved
2021-12-07 17:18 henry Resolution open => fixed
2021-12-07 17:18 henry Fixed in Version => dev
2021-12-07 17:18 henry Note Added: 0012293