View Issue Details

IDProjectCategoryView StatusLast Update
0003755OpenFOAMBugpublic2021-11-25 10:10
ReportertniemiAssigned Tohenry 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versiondev 
Fixed in Versiondev 
Summary0003755: MaxwellStefanFourier, crash if calling j() or divj() for default specie
DescriptionIn MaxwellStefanFourier, if calling j() (or divj) for default specie the code will crash because jexp_ has not been allocated. This problem is not severe as j() is not needed to obtain the simulation results. However, calling j() might be interesting for eg. post-processing, in which case if looping over all species, the code will crash.



TagsNo tags attached.

Activities

henry

2021-11-24 11:19

manager   ~0012270

The default specie is not solved for so divj() should not be needed and it is not clear how either divj() or j() should be calculated, it could be based on the balance from the solution of the equation system or assuming that the net diffusion is 0, i.e. from the -sum of all the other species. Either approach will be expensive for divj() and it is not clear it is needed but would be OK for j().

tniemi

2021-11-24 11:32

reporter   ~0012271

Yes, I would say modifying divj() is unnecessary, or at least I have never routinely used it for anything outside of the solvers. I guess the -sum approach would be reasonable for j() and I think it would be consistent with q(). As said, this is not a big deal but it would be nice not to have to escape the default specie when checking diffusion fluxes.

henry

2021-11-24 14:54

manager   ~0012272

Try with commit e931ccada1152fd6ca527c11b2a5caa2dba91394

tniemi

2021-11-25 08:38

reporter   ~0012275

Thanks! Seems to be working.

Issue History

Date Modified Username Field Change
2021-11-24 08:30 tniemi New Issue
2021-11-24 11:19 henry Note Added: 0012270
2021-11-24 11:32 tniemi Note Added: 0012271
2021-11-24 14:54 henry Note Added: 0012272
2021-11-25 08:38 tniemi Note Added: 0012275
2021-11-25 10:10 henry Assigned To => henry
2021-11-25 10:10 henry Status new => resolved
2021-11-25 10:10 henry Resolution open => fixed
2021-11-25 10:10 henry Fixed in Version => dev