View Issue Details

IDProjectCategoryView StatusLast Update
0003666OpenFOAMPatchpublic2022-04-06 16:35
ReporterlorenzotrevisanAssigned Tohenry 
PrioritylowSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSSlackwareOS Version14.2
Product Versiondev 
Fixed in Versiondev 
Summary0003666: Some small fixies for coolingSphere turorial
DescriptionIn tutorials/heatTransfer/chtMultiRegionFoam/coolingSphere/constant/:

- transportProperties should not be needed due to the considered solver does include energy/heat;

- momentumTransport should not be needed because turbulence model is defined in tutorials/heatTransfer/chtMultiRegionFoam/coolingSphere/templates/materials/ for each fluid.


In tutorials/heatTransfer/chtMultiRegionFoam/coolingSphere/templates/materials/water/thermophysicalProperties Prandtl number is set to 0.7 [-], but typical value for liquid water is about 7 [-].
TagsNo tags attached.

Activities

lorenzotrevisan

2022-04-06 09:51

reporter   ~0012536

re-reading the description written a year ago, I realize that it doesn't make much sense as I wrote it. As it is not editable, I rephrase the remark:

In tutorials/heatTransfer/chtMultiRegionFoam/coolingSphere/constant/ the files transportProperties and momentumTransport are superfluous, because already specified in the templates for all the materials.

I noted that in the actual OpenFOAM-dev sources these files have already been deleted, and Prandtl number for water in templates/materials/water/physicalProperties is correct with a value of 7 [-].

So I am sorry for the bad formulation of the issue due to my poor skill (I'm still learning ;-), and ask to close the issue because already resolved.

I take this opportunity to thank you for this really useful tutorial.

henry

2022-04-06 16:35

manager   ~0012537

Resolved in OpenFOAM-dev by commit 4b65112182e439d2ef51f79992b63f57f4d155b9

Issue History

Date Modified Username Field Change
2021-04-26 16:20 lorenzotrevisan New Issue
2022-04-06 09:51 lorenzotrevisan Note Added: 0012536
2022-04-06 16:34 henry Assigned To => henry
2022-04-06 16:34 henry Status new => resolved
2022-04-06 16:34 henry Resolution open => fixed
2022-04-06 16:34 henry Fixed in Version => dev
2022-04-06 16:35 henry Note Added: 0012537