View Issue Details

IDProjectCategoryView StatusLast Update
0003589ThirdParty[All Projects] Bugpublic2020-11-11 12:00
ReporterKyleAssigned Towill 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOSOtherOS Version(please specify)
Product Versiondev 
Fixed in Version8 
Summary0003589: Threshold not working on lagrangian data
DescriptionHello,

When trying to threshold the data from the lagrangian solve it doesn't work. I have to the glyph the data then threshold to get it to work which messes up the data. I don't have this issue when using the v2006. It is also not possible to threshold the data once I have foamToVTk the data.
Steps To ReproduceRun the cyclone tutorial can and threshold the data.
Additional InformationI did this on windows.
TagsNo tags attached.

Activities

henry

2020-11-09 19:45

manager   ~0011670

It is not clear if you are referring to a problem in OpenFOAM or ParaView. The ParaView threshold functionality does not relate directly to OpenFOAM so it maybe that you are seeing a problem with the ParaView version you are using.

> Run the cyclone tutorial can and threshold the data.

This is not sufficient information to reproduce the problem, could you provide more detail?

Kyle

2020-11-09 20:25

reporter   ~0011671

Hi,
I like the changes that were made to the lagrangian solvers so I moved my MPPIC case, that I setup in v2006, to the reactingParticelFoam solver so I can model the heat transfer from the hot gas to a limestone cloud.
When I got my case running and got some of the data lagrangian data I first tried to use paraFoam but that would not load the .openFOAM reader. I then used foamToVTK to get the data into VTK format and then loaded it into ParaView 5.8. applied a threshold filter but it wouldn't actual threshold the data as I want to see only the particles less with an age less than one second. I could do this with the MPPIC lagrangian cloud data that was changed to VTK with foamToVTK from v2006.
I tested to see if it was some setup issue by running the \tutorials\lagrangian\denseParticleFoam\cyclone case to 1.3 seconds and then changing it to VTK with foamToVTK. I would load that into ParaView 5.8 and the threshold filter will not work unless I apply a glyph filter to the data first and then apply the threshold.

I have not tried to see if it works in ubuntu. I will see if I get time tomorrow.

I am also not sure if this is a ParaView or OpenFOAM issue. I know that the two versions save the lagrangian results in different formats and that KitWare only supports the .com version with a builtin reader. But if it doesn't work after changing it to VTK surely it must be OpenFOAM then?

I hope this clears things up.

henry

2020-11-09 21:44

manager   ~0011672

There are some serious bugs in ParaView-5.8 so we are using ParaView-5.6.3.

henry

2020-11-09 21:58

manager   ~0011673

I ran the cyclone in OpenFOAM-dev to 1.3s, loaded the Lagrangian data for time 1.3s into ParaView-5.6.3 using the paraFoam reader and thresholded on age from 0 to 0.1s and it works fine.

Kyle

2020-11-10 04:38

reporter   ~0011674

Okay, thanks. I will look into it a bit further on my side to try and get paraFoam to load the reader correctly.

Kyle

2020-11-10 16:45

reporter   ~0011675

Hello,

I looked into a bit further and it seemed to be an issue with the foamToVTk function of the lagrangian data.
I got paraFoam working correctly but removing and purging and the dev and parafoam and reinstalling. Then closing the ubuntu shell and Xming and reopening it. Now paraFoam is working correctly and able to load .openFOAM files and the threshold works. Now I tested the foamToVTK on the complete case of the cyclone tutorial by reconstructing the data and running foamToVTK (just foamToVTK no extra arguments). I open the vtk file after in paraFoam and it can not threshold the data. I then reloaded the case using the PVreader to load the data and exported from paraFoam to a VTM file. This work correctly in 5.8 and parafoam. This to me points to an issue with the foamToVTK.

will

2020-11-11 09:09

manager   ~0011676

I cannot reproduce this. The age data (and everything else) is present in the VTK output, and Paraview 5.6.3 and 5.8.1 have no problem loading it and applying a threshold. I do not have Paraview 5.8.0 installed.

If you want us to investigate further, please upload the VTK file in question as well as a Paraview state file showing how you are viewing it (File > Save State).

However, I suspect that this is either an issue of usage or a bug in the version of Paraview that you are using. In either of these cases we will not be able to help. Paraview's bug tracker can be found here: https://gitlab.kitware.com/paraview.

Kyle

2020-11-11 10:29

reporter   ~0011677

Hello,

Please see the attached vtk data.

cloud_6000.vtk (1,768,138 bytes)
save_state_threshold.pvsm (263,367 bytes)

will

2020-11-11 10:33

manager   ~0011678

Apologies for the above. I can now see the issue. The problem is that the lagrangian VTK files only have the points listed. They have no VERTICES section, which is needed for them to display by default and for various filters to work. We will add this.

will

2020-11-11 12:00

manager   ~0011679

Resolved in dev and in version 8 by the following commits:

https://github.com/OpenFOAM/OpenFOAM-dev/commit/93357284dbc9ee39a6334bd1135a644044f421fe
https://github.com/OpenFOAM/OpenFOAM-8/commit/340defec456f31b70645f29e78ffed1e6ede5a8e

Issue History

Date Modified Username Field Change
2020-11-09 18:57 Kyle New Issue
2020-11-09 19:45 henry Note Added: 0011670
2020-11-09 20:25 Kyle Note Added: 0011671
2020-11-09 21:44 henry Note Added: 0011672
2020-11-09 21:58 henry Note Added: 0011673
2020-11-10 04:38 Kyle Note Added: 0011674
2020-11-10 16:45 Kyle Note Added: 0011675
2020-11-11 09:09 will Note Added: 0011676
2020-11-11 10:29 Kyle File Added: cloud_6000.vtk
2020-11-11 10:29 Kyle File Added: save_state_threshold.pvsm
2020-11-11 10:29 Kyle Note Added: 0011677
2020-11-11 10:33 will Note Added: 0011678
2020-11-11 12:00 will Assigned To => will
2020-11-11 12:00 will Status new => resolved
2020-11-11 12:00 will Resolution open => fixed
2020-11-11 12:00 will Fixed in Version => 8
2020-11-11 12:00 will Note Added: 0011679