View Issue Details

IDProjectCategoryView StatusLast Update
0003538OpenFOAMBugpublic2020-08-24 12:00
ReporterTiberias_Assigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version18.04
Product Version8 
Fixed in Version8 
Summary0003538: PressureDifferencePatch gives missing keyword error due to missing semicolon in .cfg
DescriptionWhen running a case with #includeFunc pressureDifferencePatch in Version 8, I get the error:

--> FOAM FATAL IO ERROR:
keyword operation is undefined in dictionary "...

The keyword "operation" is defined in pressureDifference.cfg which is included by pressureDifferencePatch.cfg.
In pressureDifference.cfg the entry "operation subtract;" is defined but i guess the error occurs due to a missing semicolon after the previous entry "writeInterval 1"
When I add the semicolon the case will run without error.

The semicolon is already missing in version 7 but the keyword "operation" changed position from top to right after the "writeInterval" keyword, so in version 7 the bug was not recognized.
TagsNo tags attached.

Activities

henry

2020-08-24 12:00

manager   ~0011475

Resolved by commit aac9bf5c932141ef70582e0db651eabcb88e55e7

Issue History

Date Modified Username Field Change
2020-08-24 11:46 Tiberias_ New Issue
2020-08-24 12:00 henry Assigned To => henry
2020-08-24 12:00 henry Status new => resolved
2020-08-24 12:00 henry Resolution open => fixed
2020-08-24 12:00 henry Fixed in Version => 8
2020-08-24 12:00 henry Note Added: 0011475