View Issue Details

IDProjectCategoryView StatusLast Update
0003519OpenFOAMFeaturepublic2020-07-11 17:22
ReporteralbertopAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSOtherOS Version(please specify)
Product Versiondev 
Fixed in Versiondev 
Summary0003519: Changes to Intel MPI directory structure
DescriptionIntel has changed the directory structure of their MPI libraries for versions higher than 18.x.

In versions older than 19, MPI_ROOT needed to point to

<system_dependent_path>/intel/20.0/impi/yyyy.xx.xxx

It now should point to:

<system_dependent_path>/intel/20.0/impi/yyyy.xx.xxx/intel64

This change does not impact OpenFOAM, since it must be set explicitly by users. The following changes however were also made, which impact the OpenFOAM settings:

1) In wmake/rules/General/mplibINTELMPI64, the PLIBS flag should become:

PLIBS = -L$(MPI_ARCH_PATH)/lib/release -lmpi

2) In in OpenFOAM/OpenFOAM-dev/etc/config.sh/mpi, INTELMPI section, the _foamAddLib line should be:

_foamAddLib $MPI_ARCH_PATH/lib/release

The latter path becomes $MPI_ARCH_PATH/lib/debug for debug mode and $MPI_ARCH_PATH/lib/release_mt for the multi-threaded optimized library.
TagsNo tags attached.

Activities

henry

2020-07-11 17:22

manager   ~0011416

Resolved by commit 077138942f3245feb5c16ea2b119e021dd7db58d

Issue History

Date Modified Username Field Change
2020-07-09 02:49 albertop New Issue
2020-07-11 17:22 henry Assigned To => henry
2020-07-11 17:22 henry Status new => resolved
2020-07-11 17:22 henry Resolution open => fixed
2020-07-11 17:22 henry Fixed in Version => dev
2020-07-11 17:22 henry Note Added: 0011416