View Issue Details

IDProjectCategoryView StatusLast Update
0003473OpenFOAMBugpublic2020-04-01 17:05
Reporterjkim2000Assigned Tohenry 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformIntel PCOSubuntu OS Version18.04
Product Version7 
Fixed in Versiondev 
Summary0003473: wallHeatFlux and P1 radiation
DescriptionDuring postProcessing with wallHeatFlux, it was found that P1 radiation heat flux is not added, and only the convective heat flux is calculated and saved in the field of "wallHeatFlux"

It was expected that wallHeatFlux in the case with P1 radiation must be larger than WallHeatFlux in the case without radiation.
But, the wallHeatFlux function gives same heat flux in the cases without radiation and with P1 radiation

The problem is from that in P1.C code read-option of qr is NO_READ. On the contrary in FvDOM.C read-option of qr is READ_IF_PRESENT, which means that an object of the P1 radiation model created by wallHeatFlux function does not read the qr field.

When the read-option of qr in P1.C code is changed to READ_IF_PRESENT, wallHeatFlux function gives the sum of convective and radiative heat flux
TagsNo tags attached.

Activities

jkim2000

2020-04-01 12:15

reporter  

P1.C (6,606 bytes)

henry

2020-04-01 17:05

manager   ~0011279

Resolved by commit 4867477252f4da773ea4bb5bd03d2740d88f2d00

Issue History

Date Modified Username Field Change
2020-04-01 12:15 jkim2000 New Issue
2020-04-01 12:15 jkim2000 File Added: P1.C
2020-04-01 17:05 henry Assigned To => henry
2020-04-01 17:05 henry Status new => resolved
2020-04-01 17:05 henry Resolution open => fixed
2020-04-01 17:05 henry Fixed in Version => dev
2020-04-01 17:05 henry Note Added: 0011279