View Issue Details

IDProjectCategoryView StatusLast Update
0003464OpenFOAMBugpublic2020-08-05 10:40
ReporterdscianAssigned Towill 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionsuspended 
PlatformGNU/LinuxOSUbuntuOS Version19.10
Product Versiondev 
Fixed in Version 
Summary0003464: Unstable packing model in MPPICFoam without the isotropy model
DescriptionMPPICFoam shows very inaccurate results in Goldschmidt tutorial case with the isotropy model deactivated. It is even worse when there is no inlet flow in the simulation in which the max volume fraction was around 19 at the end. I will attach two videos that clearly show the issue. I don't know where the bug is but this is quite an issue as the isotropy model should be optional to MP-PIC. I have also tested a silo case (explicit) which diverged at about 0.8s and column tutorial case (implicit) which diverged at 0.28s.
Steps To ReproduceRun $FOAM_TUTORIALS/lagrangian/MPPICFoam/Goldschmidt case without the isotropy model.
Additional InformationIn the no-flow case, disabling the drag force affects the result drastically. Although it becomes better, it still remains unphysical. Damping model was off in all cases.
TagsNo tags attached.

Relationships

related to 0003385 resolvedhenry DPMFoam - "SemiImplicit" scheme for the source term gives unphysical fluid velocity distribution around the parcel 

Activities

dscian

2020-03-04 00:35

reporter  

goldschmidt.mp4 (1,641,906 bytes)

dscian

2020-03-04 00:36

reporter  

goldschmidt_noFlow.mp4 (1,860,351 bytes)

will

2020-03-04 16:13

manager   ~0011228

Do you see this with version 7? The cyclone tutorial has stopped working since version 7, and I don't know why. Might these be related?

will

2020-03-04 16:18

manager   ~0011229

Oh, yes. There's a bug in dev. Look at the difference in the column case.

column.png (54,752 bytes)
column.png (54,752 bytes)

dscian

2020-03-04 21:02

reporter   ~0011231

Yes there is a considerable difference. I see this with version 7 as well. This packing behaviour made me think that there is something to do with the averaging method but I am not sure though. It is hard to track this bug. For me, column case without the isotropy model hangs at about 0.28s and the same happens with cellPointWallModified interpolation for U.air. There happens to be overpacking which is not usual with the implicit method. On the other hand if the drag force is disabled, the simulation runs till the end but then there is excessive scattering. This should be irrelevant to the averaging method.

will

2020-03-05 08:47

manager   ~0011232

The image I posted is the difference between 7 and dev. If you see your problem in 7, too, then that is a
different issue.

MPPIC has stability issues. Mostly this is when the parcels are too large relative to the cells, meaning a reliable average cannot be computed. There are other issues, too, though. When we wrote this, doing MPPIC reliably on polyhedral meshes wasn't a solved problem, and the only references we had when we first did the implementation were structured-mesh codes (Barracuda and Mfix) in which stability was achieved by various staggering procedures only possible on structured meshes. That situation may have changed now, I don't know.

There has been zero funding for improvement or extension of MPPIC since it's first release in 2013. If the basic limitations of our implementation of MPPIC is the issue here, then that will require someone to pay for additional research and development work to resolve it.

I'll find the bug that is causing the difference between 7 and dev. That's clearly a bug that has been introduced since version 7, and we have funding available (https://openfoam.org/maintenance) to do maintenance work of this sort.

Removing drag and isotropy will cause more scattering. Both act to reduce relative velocities within the system. Both will, in all likelihood, be necessary to get a physical solution. Damping, too, is important, as it is the only mechanism by which the sub-grid collision modelling dissipates energy. However, it can interact badly with the packing models. Again, limitations that we have never had the opportunity to fix.

dscian

2020-03-06 08:59

reporter   ~0011234

Thank you for the clarification and detailed explanation. I understand that the other issue is clearly a matter of funding. I just think that OpenFOAM is a great platform for MP-PIC too and could be quite unique with further developments which obviously require funding. I wish the big players in this field would be interested in it. Thanks in advance for your effort to find the bug that causes the difference between version 7 and dev.

will

2020-08-05 10:40

manager   ~0011443

The issue with the staggering has been resolved by commit 43d66b5e. See https://bugs.openfoam.org/view.php?id=3385#c11442 for explanation.

The issue regarding instability in the absence of the isotropy model is suspended pending funding.

Issue History

Date Modified Username Field Change
2020-03-04 00:35 dscian New Issue
2020-03-04 00:35 dscian File Added: goldschmidt.mp4
2020-03-04 00:36 dscian File Added: goldschmidt_noFlow.mp4
2020-03-04 16:13 will Note Added: 0011228
2020-03-04 16:18 will File Added: column.png
2020-03-04 16:18 will Note Added: 0011229
2020-03-04 21:02 dscian Note Added: 0011231
2020-03-05 08:47 will Note Added: 0011232
2020-03-06 08:59 dscian Note Added: 0011234
2020-08-05 10:39 will Relationship added related to 0003385
2020-08-05 10:40 will Assigned To => will
2020-08-05 10:40 will Status new => closed
2020-08-05 10:40 will Resolution open => suspended
2020-08-05 10:40 will Note Added: 0011443