View Issue Details

IDProjectCategoryView StatusLast Update
0003452OpenFOAMBugpublic2020-02-15 12:21
Reporteropenfoam_ranAssigned Tohenry 
PrioritylowSeveritytrivialReproducibilityalways
Status closedResolutionno change required 
PlatformUnixOSOtherOS Version(please specify)
Product Versiondev 
Fixed in Version 
Summary0003452: Copyright banner in each file
Description
I recent want to write Bash script to extend the usage of OpenFOAM.

I would like to follow the tradition of GNP project. However, I don't know the following behavior will voliate the GPL v3 license.


Make it simple:

I want to this source block:

#+begin_src bash

#!bin/bash
#------------------------------------------------------------------------------
# |
# This need | TEM: XX Elemetn Method
# | Website: xxx
# Further refine | Copyright (C) 2018-2020 user
# |
#------------------------------------------------------------------------------
# License
# This file is part of TEM.
#
# TEM is free software: you can redistribute it and/or modify it
# under the terms of the GNU General Public License as published by
# the Free Software Foundation, either version 3 of the License, or
# (at your option) any later version.
#
# TEM is distributed in the hope that it will be useful, but WITHOUT
# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
# for more details.
#
# You should have received a copy of the GNU General Public License
# along with TEM. If not, see <http://www.gnu.org/licenses/>.
#
# Script
# Allrun.sh
#
# Description
#
# Just like the role of James T. Kirk
#
# Want to read more of his story, visit:
#
# https://en.wikipedia.org/wiki/James_T._Kirk
#
#------------------------------------------------------------------------------
#+end_src


to replace with the flowing code block in every file in my software.


#+begin_src bash
#----------------------------------*-sh-*--------------------------------------
# ========= |
# \\ / F ield | OpenFOAM: The Open Source CFD Toolbox
# \\ / O peration | Website: https://openfoam.org
# \\ / A nd | Copyright (C) 2011-2019 OpenFOAM Foundation
# \\/ M anipulation |
#------------------------------------------------------------------------------
# License
# This file is part of OpenFOAM.
#
# OpenFOAM is free software: you can redistribute it and/or modify it
# under the terms of the GNU General Public License as published by
# the Free Software Foundation, either version 3 of the License, or
# (at your option) any later version.
#
# OpenFOAM is distributed in the hope that it will be useful, but WITHOUT
# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
# for more details.
#
# You should have received a copy of the GNU General Public License
# along with OpenFOAM. If not, see <http://www.gnu.org/licenses/>.
#
# File
# etc/bashrc
#
# Description
# Startup file for OpenFOAM
# Sourced from ~/.profile or ~/.bashrc
# Should be usable by any POSIX-compliant shell (eg, ksh)
#
#------------------------------------------------------------------------------
#+end_src


Is this okay with the OpenFOAM foundation.


Sincerely,

Ran
Steps To ReproduceNULL
Additional InformationNULL
TagsNo tags attached.

Activities

openfoam_ran

2020-02-13 20:25

reporter   ~0011171

1. GNP is GNU
2. Is this okay with the OpenFOAM foundation.

   should be

Is this okay with the OpenFOAM foundation?

henry

2020-02-13 20:34

manager   ~0011172

It is not clear what you are planning to do, could you please clarify?

openfoam_ran

2020-02-13 20:42

reporter   ~0011173

I would like to use OpenFOAM.

Everyfile in the OpenFOAM has such a banner:

An example is: https://github.com/OpenFOAM/OpenFOAM-dev/blob/2d3b02c1309c32ef23628a38c776c20dd2a4cf27/src/OpenFOAM/algorithms/dynamicIndexedOctree/dynamicIndexedOctree.H#L1-L34


I would like write my own software but in every file, I would like to make looks like this:

https://github.com/randomwangran/TEM/blob/e2bb39360083bead502296b066aefc34289ba828/workingFolder/Allrun.sh#L1-L36

Is this okay with the OpenFOAM foundation?

henry

2020-02-15 12:21

manager   ~0011180

You will need to discuss this directly with the OpenFOAM Foundation rather than on the OpenFOAM bug-tracker as this does not relate to the maintenance or development of OpenFOAM.

Issue History

Date Modified Username Field Change
2020-02-13 20:21 openfoam_ran New Issue
2020-02-13 20:25 openfoam_ran Note Added: 0011171
2020-02-13 20:34 henry Note Added: 0011172
2020-02-13 20:42 openfoam_ran Note Added: 0011173
2020-02-15 12:21 henry Note Added: 0011180
2020-02-15 12:21 henry Assigned To => henry
2020-02-15 12:21 henry Status new => closed
2020-02-15 12:21 henry Resolution open => no change required