View Issue Details

IDProjectCategoryView StatusLast Update
0003451OpenFOAMBugpublic2020-02-14 13:30
Reportermichael.mueller-wrdAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOScentOSOS Version(please specify)
Product Version7 
Fixed in Versiondev 
Summary0003451: chtMultiRegionFoam: postProcess functions use global caseDicts function files instead case specific files in local ./system/
DescriptionFor example in the heatedDuct tutorial, to extract vtk surfaces in post-processing step, I copied the global file via "foamGet surfaces" into the system directory.
Then, I adapted the settings of the surfaces (name, basePoint. normalVector etc.) so that there is only one surface included (name z_cL, see below).
I tried to post-process via:
chtMultiRegionFoam -postProcess -latestTime -func surfaces -region metal

But only the global surfaces (located in .../etc/caseDicts/postProcessing/visualization/surfaces) are processed, ie. xNormal, yNormal yNormal, p100, CAD.

When I rename the local system/surfaces file to system/surfacesTMP, and again:
chtMultiRegionFoam -postProcess -latestTime -func surfacesTMP -region metal
... it works as expected, processing only the locally specified surfaces.

I don't understand, why the global surfaces file is used in the former case. At least in the case described here, this behaviour is not intended.
By the way, the same problem occurs for streamlines functionality as well.

PS: the methodology itself works fine for me in case of single region cases (simpleFoam etc.)
Steps To ReproduceTry any chtMultiRegionFoam tutorial, use foamGet to copy surfaces file... see above.
Additional Informationcontent of system/surfaces tested with heatedDuct tutorial:
#includeEtc "caseDicts/postProcessing/visualization/surfaces.cfg"

fields (T);

surfaces
(
    z_cL
    {
        $cuttingPlane;
        pointAndNormalDict
        {
            basePoint (0 0 0.1); // Overrides default basePoint (0 0 0)
            normalVector (0 0 1); // $z: macro for (0 0 1)
        }
    }

);
TagsNo tags attached.

Activities

henry

2020-02-12 16:30

manager   ~0011170

Try with OpenFOAM-dev

michael.mueller-wrd

2020-02-14 13:00

reporter   ~0011174

Works as expected with OpenFOAM-dev.

Thanks.

Issue History

Date Modified Username Field Change
2020-02-12 15:35 michael.mueller-wrd New Issue
2020-02-12 16:30 henry Note Added: 0011170
2020-02-14 13:00 michael.mueller-wrd Note Added: 0011174
2020-02-14 13:30 henry Assigned To => henry
2020-02-14 13:30 henry Status new => resolved
2020-02-14 13:30 henry Resolution open => fixed
2020-02-14 13:30 henry Fixed in Version => dev