View Issue Details

IDProjectCategoryView StatusLast Update
0003443OpenFOAMBugpublic2020-02-07 16:16
Reporterbakonyi.daniAssigned Tohenry 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOSUbuntuOS Version18.04
Product Version7 
Fixed in Version7 
Summary0003443: nutkAtmRoughWallFunction not working properly in OpenFOAM 7
DescriptionI was trying to create a simple 2D case for an atmospheric boundary layer flow in OpenFOAM7 to check the consistency of the inlet and outlet profiles, but I had zero luck recreating anything I found in the literature (the outflow U, k, eps and nut all were very different). By elimination I finally found that the nutkAtmRoughWallFunction BC behaved strangely. It was totally unresponsive to any change of kappa or z0 inputs. I have read in the OpenFoam 7 release notes that the nutkRoughWallFunction code was updated, which made me suspicious and I quickly checked the case in OpenFOAM 6 as well. The problem went completely away, so it appears to be a bug in OpenFOAM 7 (maybe due to the changes made to nutkRoughWallFunction, but I don't have the skills jet to investigate any further).
Steps To ReproduceSimply run the case in OpenFOAM 6 vs. 7:
https://bitbucket.org/BPPRepo/nutkatmroughwallfunction_test/src/master/
I used ParaView to visualize the profiles (the state is also included).
TagsNo tags attached.

Activities

henry

2020-02-06 18:12

manager   ~0011135

Can you reproduce the problem in the tutorial case: tutorials/incompressible/simpleFoam/turbineSiting

I have run this case in OpenFOAM-6, 7 and dev and get the same results for all three versions.

bakonyi.dani

2020-02-06 19:50

reporter   ~0011136

That is strange...
I have uploaded a comparison of the vertical profiles (at the outlet, of U, k, eps etc.) I got from both the nutkAtmRoughWall and turbineSiting cases:
https://drive.google.com/drive/folders/12iMIpLipg5w9HaxRk6ciPuBby-QarCWd
They are very different for me.

henry

2020-02-06 21:43

manager   ~0011138

Try this:

commit ac27a25923cde9fd468ec09944b7c3a9872e8215
Author: Henry Weller <http://openfoam.org>
Date: Thu Feb 6 21:42:26 2020 +0000

    nutkAtmRoughWallFunction: Updated calcNut -> nut
    
    Resolves bug-report https://bugs.openfoam.org/view.php?id=3443

bakonyi.dani

2020-02-07 16:07

reporter   ~0011149

It worked! I am now getting the same results as with OF6.
Thank you!

henry

2020-02-07 16:16

manager   ~0011150

Resolved in OpenFOAM-7 by commit ac27a25923cde9fd468ec09944b7c3a9872e8215
Resolved in OpenFOAM-dev by commit 6a2ecb4d0441e9a4906c71a577b626bcb6ff72b6

Issue History

Date Modified Username Field Change
2020-02-06 16:10 bakonyi.dani New Issue
2020-02-06 18:12 henry Note Added: 0011135
2020-02-06 19:50 bakonyi.dani Note Added: 0011136
2020-02-06 21:43 henry Note Added: 0011138
2020-02-07 16:07 bakonyi.dani Note Added: 0011149
2020-02-07 16:16 henry Assigned To => henry
2020-02-07 16:16 henry Status new => resolved
2020-02-07 16:16 henry Resolution open => fixed
2020-02-07 16:16 henry Fixed in Version => 7
2020-02-07 16:16 henry Note Added: 0011150