View Issue Details

IDProjectCategoryView StatusLast Update
0003413OpenFOAMBugpublic2019-12-19 14:25
ReporterSteffenBAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Fixed in Versiondev 
Summary0003413: foamSetupCHT creates wrong regionProperties if no fluid included
DescriptionWhen using the template file for creating a chtMultiRegionFoam case regionProperties requires an entry for fluid. If no fluid is included in the case (pure conduction model) the "foamSetupCHT" command creates a regionProperties file containing this:
regions 1 ( solid 2 ( body1 body2 ) );

The required structure for chtMultiRegionFoam in this case would be
 regions 2 ( fluid 0 () solid 2 ( body1 body2 ) );

I guess this just needs to be changed in the script of foamSetupCHT.
TagsNo tags attached.

Activities

henry

2019-12-17 14:12

manager   ~0010987

Could you provide a suitable case and steps to reproduce the problem?

SteffenB

2019-12-18 12:58

reporter   ~0010989

Ok. I modified the chtMultiRegionFoam tutorial case of the coolingSphere to fit my problem. I renamed the "fluid" region into outerSolid and adjusted the boundary in the templates/solids/T file to fit.
Then i ran "Allmesh" and used "foamSetupCHT" afterwards. This way the problematic regionProperties file is created in constant. And chtMultiRegionFoam stops, when started, because "fluid" is missing in the regionProperties file.
After adjusting this file the way I previously mentioned (I appended the correct regionProperties file in the main folder of the given example), the simulation works flawlessly.

regionProperties_case.zip (76,611 bytes)

henry

2019-12-19 14:25

manager   ~0010990

Resolved by commit a9ddd758e8f16815c7c3252867844af03437f63b

Issue History

Date Modified Username Field Change
2019-12-17 08:35 SteffenB New Issue
2019-12-17 14:12 henry Note Added: 0010987
2019-12-18 12:58 SteffenB File Added: regionProperties_case.zip
2019-12-18 12:58 SteffenB Note Added: 0010989
2019-12-19 14:25 henry Assigned To => henry
2019-12-19 14:25 henry Status new => resolved
2019-12-19 14:25 henry Resolution open => fixed
2019-12-19 14:25 henry Fixed in Version => dev
2019-12-19 14:25 henry Note Added: 0010990