View Issue Details

IDProjectCategoryView StatusLast Update
0003205OpenFOAMBugpublic2019-03-26 23:57
ReporterkevinkAssigned Tohenry 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionreopened 
PlatformLinuxOSUbuntuOS Version18.04.02 LTS
Product Version6 
Fixed in Versiondev 
Summary0003205: prghPressure BC uses hardcoded "rho" that fails with buoyantBoussinesqPimpleFoam
DescriptionWhen trying to use the prghPressure BC with buoyantBoussinesqPimpleFoam it crashes with a failure to find rho. I tried what appeared to be an option in the tutorial of specifying "rho rhok;" in the p_rgh file BC, but that had no effect. I had to change "rho" to "rhok" in the PrghPressureFvPatchScalarField.C, and rebuild the finiteVolume library and then rebuild buoyantBoussinesqPimpleFoam with this library to see if it would work, and it does, but that is a very poor solution, just tried to make sure it works. I am new enough to OpenFOAM that I don't quite see what the current best approach to solving this is. I removed the "rho rhok;" mapping in the tutorial and it still worked, so it appears that things have changed since that tutorial was constructed. Maybe there is now a more robust method of handling this than creating a dictionary key that remaps rho to rhok, but if not, that is what I will probably do so that I don't need to have two versions around.

This is essentially a duplicate of 3192, but that was closed for reasons that are not apparent, so I guess that I have to create this anew.
Steps To ReproduceTry to use a prghPressure BC with buoyantBoussinesqPimpleFoam.
TagsNo tags attached.

Activities

henry

2019-03-21 21:44

manager   ~0010388

Last edited: 2019-03-21 21:52

View 3 revisions

The prghPressure BC cannot be used with the buoyantBoussinesqPimpleFoam solver as it is an incompressible solver and hence does not have a density field in the standard sense but does have a constant reference "kinematic" density field rhok which is dimensionless.

henry

2019-03-21 21:49

manager   ~0010389

Last edited: 2019-03-21 21:54

View 2 revisions

Maybe the best approach would be to rename the rhok field rho but to operate in an equivalent manner to rho it would need to be dimensioned and the equations changed. Basically this solver is not compatible with the standard compressible solver BCs and special versions of all of them would need to be created.

We would rather get rid of the buoyantBoussinesqPimpleFoam solver altogether and we recommend using buoyantPimpleFoam instead with the Boussinesq equation of state.
We will put buoyantBoussinesqPimpleFoam and buoyantBoussinesqSimpleFoam on the deprecated list.

henry

2019-03-26 23:57

manager   ~0010397

Resolved in OpenFOAM-dev by commit 9bf34679bd2c7c122eb75b967a52e1c814bc080e

Issue History

Date Modified Username Field Change
2019-03-21 21:33 kevink New Issue
2019-03-21 21:44 henry Assigned To => henry
2019-03-21 21:44 henry Status new => closed
2019-03-21 21:44 henry Resolution open => no change required
2019-03-21 21:44 henry Note Added: 0010388
2019-03-21 21:46 henry Note Edited: 0010388 View Revisions
2019-03-21 21:49 henry Status closed => feedback
2019-03-21 21:49 henry Resolution no change required => reopened
2019-03-21 21:49 henry Note Added: 0010389
2019-03-21 21:52 henry Note Edited: 0010388 View Revisions
2019-03-21 21:54 henry Note Edited: 0010389 View Revisions
2019-03-26 23:57 henry Status feedback => resolved
2019-03-26 23:57 henry Fixed in Version => dev
2019-03-26 23:57 henry Note Added: 0010397