View Issue Details

IDProjectCategoryView StatusLast Update
0003203OpenFOAMBugpublic2019-03-19 16:39
Reporterniklas.wikstromAssigned Tohenry 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinux x86_64OSFedoraOS Version29
Product Versiondev 
Fixed in Version6 
Summary0003203: blockMesh false faces on axis in wedge block
Description
When generating a mesh for 2D axisymmetric case with blockMesh, an invalid mesh results for some block parameter combinations. The mesh error seems to emanate from that the axis (aligned with the collapsed block edges) has a non-zero amount of faces (although fewer than the number of edges along the axis).

Same case works fine with OpenFOAM-5.x.
Steps To Reproduce1) Unpack attached example case
2a) blockMesh -dict system/blockMeshDict_OK # Should produce a valid mesh ( axis face count = 0)
2b) blockMesh -dict system/blockMeshDict_ERR # Should produce an invalid mesh (axis face count = 2)
3) checkMesh #Floating pt exception
Additional InformationThe problem is also present when running with docker image docker.io/openfoam/openfoam-dev-paraview56
TagsNo tags attached.

Activities

niklas.wikstrom

2019-03-19 11:14

reporter  

blockMeshProblem.tgz (5,194 bytes)

henry

2019-03-19 16:39

manager   ~0010384

Resolved in OpenFOAM-6 by commit eb0ce5d792a191b0a1a2e13add127245ee7c2136
Resolved in OpenFOAM-dev by commit f0c3c497e7d0945f69078cb1751751dd0e542ce5

Issue History

Date Modified Username Field Change
2019-03-19 11:14 niklas.wikstrom New Issue
2019-03-19 11:14 niklas.wikstrom File Added: blockMeshProblem.tgz
2019-03-19 16:39 henry Assigned To => henry
2019-03-19 16:39 henry Status new => resolved
2019-03-19 16:39 henry Resolution open => fixed
2019-03-19 16:39 henry Fixed in Version => 6
2019-03-19 16:39 henry Note Added: 0010384