View Issue Details

IDProjectCategoryView StatusLast Update
0003170OpenFOAMBugpublic2019-02-21 17:49
ReporterblttkglAssigned Tohenry 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOSUbuntuOS Version16.04
Product Version6 
Fixed in Versiondev 
Summary0003170: Unphysical pressure field (decoupling) with fine grid and high momentum spray
DescriptionWhen a high momentum non-reacting spray is simulated using sprayFoam, it results with unphysical pressure field originating from the spray. This occurs even though the continuity and residuals are quite low throughout the simulation. The same grid-injection case with exact same settings does not show this pressure behavior in other (2.4.x, 4.x and 5.x tested) OpenFOAM versions.
Steps To ReproduceI tried to reproduce this case in aachenBomb tutorial to make things simple but couldn't manage it. Therefore I add a heavily simplified version of my actual case that gives the same error.

1- Execute the createMesh bash script to generate the mesh and the refinement region
2- Run the simulation using sprayFoam solver (OF6) until about 0.2 ms. With a single core this should take about 30 mins, with multicore less. Check the velocity and pressure fields to see the fluctuations around the spray.
3- Run the same case with different OpenFOAM versions (I tested 4.x and 5.x, 4.x requires PBiCGStab solver be changed to PBiCG) and check the velocity and pressure fields. No fluctuation.
Additional InformationI have gone through commits made to the a) SolutionControl and b) Lagrangian particle class between 5 and 6 and could not notice any change that might result with this except for solution control commit 4c81227 introducing major changes to the pimple solution control and LPT class commit 11a3b3b synchronizing random number generation. My opinion is this fluctuation is caused by either of these changes (probably the latter since the spray shape varies greatly between different OF6 and other version simulations that I couldn't attribute to a shot-to-shot variation, check C12H26 field) but I couldn't figure out a way to fix it.
TagsNo tags attached.

Activities

blttkgl

2019-02-15 23:38

reporter  

testcase.tar.gz (199,453 bytes)

blttkgl

2019-02-16 13:12

reporter   ~0010294

I also attach a pressure field cutplane from one of my full-scale cases, using the exact same case file except for the mesh. Left side is OF6 and right side is OF5.x. sprayFoam solver.

pressure.png (111,776 bytes)
pressure.png (111,776 bytes)

will

2019-02-18 09:23

manager   ~0010295

Have you tried rolling back to either side of the commits that you identified to confirm whether or not it was these changes that made the difference?

blttkgl

2019-02-18 10:02

reporter   ~0010296

Hey, no because I have been using OpenFoam versions added as software packages to my institutions repository on my local machine, and already compiled versions in our cluster. I can check that and report it back to you though.

blttkgl

2019-02-18 21:06

reporter   ~0010299

I rolled back to the commit before syncronizing random number generation in LPT class (dev commit id 1e633784f836789a2eda8fd0dc987b157f5733c4) and ran the case I uploaded again. The fluctuations are still there. They are not as "visible" as the image I posted above due to small refinement region in the test case but they are visible in sliced images. I upload 3 images from 6, 5.x and rolled back dev run. I can also provide log files as a link if required.

images.tar.gz (312,767 bytes)

will

2019-02-20 11:30

manager   ~0010303

I think we've figured it out. It's related to the change to ddtPhiCoeff in commit da787200. We're working on it.

blttkgl

2019-02-20 12:25

reporter   ~0010307

Yes, that was what we were just testing now and looks like the cause. I'll wait for your results then.

henry

2019-02-21 14:00

manager   ~0010312

Resolved in OpenFOAM-dev by commit b162c4818b9bbdb824db9e75baffef6ac7c5a7a0

Issue History

Date Modified Username Field Change
2019-02-15 23:38 blttkgl New Issue
2019-02-15 23:38 blttkgl File Added: testcase.tar.gz
2019-02-16 13:12 blttkgl File Added: pressure.png
2019-02-16 13:12 blttkgl Note Added: 0010294
2019-02-18 09:23 will Note Added: 0010295
2019-02-18 10:02 blttkgl Note Added: 0010296
2019-02-18 21:06 blttkgl File Added: images.tar.gz
2019-02-18 21:06 blttkgl Note Added: 0010299
2019-02-20 11:30 will Note Added: 0010303
2019-02-20 12:25 blttkgl Note Added: 0010307
2019-02-21 14:00 henry Assigned To => henry
2019-02-21 14:00 henry Status new => resolved
2019-02-21 14:00 henry Resolution open => fixed
2019-02-21 14:00 henry Fixed in Version => dev
2019-02-21 14:00 henry Note Added: 0010312