View Issue Details

IDProjectCategoryView StatusLast Update
0003159ThirdParty[All Projects] Bugpublic2019-03-11 22:34
ReporterDanNielsenAssigned Tochris 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Fixed in Version6 
Summary0003159: ParaFoam/paraview QStandardPaths: XDG_RUNTIME_DIR not set
DescriptionI hav installed OpenFoam 6 on Windows, all was well until the point of opening paraFoam/paraview. it came up widt the error: QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-dan' failed to get the current screen resources.

And here after xlib extension mit-shm missing on display 0.

I tryed to instal OpenFoam5 and alle is well.
TagsNo tags attached.

Activities

wyldckat

2019-03-11 22:30

updater   ~0010361

@DanNielsen Here's what I had to do to get it up and running:

1- Have Xming installed and running on Windows.

2- Have the latest openfoam6 package installed, along with the respective package from Windows.

3- Run the following command before running paraFoam or paraview:

    export DISPLAY=:0

This is already documented at https://openfoam.org/download/windows-10/ - section: "Enabling Graphical Applications" - which has been documented there since at least June 2017, as indicated by the Wayback machine.


The issue with:

    xlib extension mit-shm missing on display 0.

has been solved in the latest ParaView package that is provided for OpenFOAM 6 and dev, which was announced on CFD Direct's newsletter.

Closing this as solved, either by Chris or Will, I'm not sure, but am assigning it to Chris.

wyldckat

2019-03-11 22:33

updater   ~0010362

Sorry, reopening just to quote the relevant announcement from the newsletter and link to the respective bug in Mesa: https://lists.freedesktop.org/archives/mesa-dev/2019-February/215484.html

wyldckat

2019-03-11 22:34

updater   ~0010363

From the March 2019 newsletter:
«Updated Ubuntu package for ParaView 5.6.0, with Mesa 18.3.4 which fixes an issue when running with WSL on Windows 10 with Xming [ more... ]»

Issue History

Date Modified Username Field Change
2019-02-04 10:09 DanNielsen New Issue
2019-03-11 22:30 wyldckat Note Added: 0010361
2019-03-11 22:31 wyldckat Assigned To => chris
2019-03-11 22:31 wyldckat Status new => resolved
2019-03-11 22:31 wyldckat Resolution open => fixed
2019-03-11 22:33 wyldckat Status resolved => feedback
2019-03-11 22:33 wyldckat Resolution fixed => reopened
2019-03-11 22:33 wyldckat Note Added: 0010362
2019-03-11 22:34 wyldckat Status feedback => resolved
2019-03-11 22:34 wyldckat Resolution reopened => fixed
2019-03-11 22:34 wyldckat Fixed in Version => 6
2019-03-11 22:34 wyldckat Note Added: 0010363