View Issue Details

IDProjectCategoryView StatusLast Update
0003144OpenFOAMBugpublic2019-01-04 13:38
ReporterjskortelAssigned Towill 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version18.04 LTS
Product Versiondev 
Fixed in Versiondev 
Summary0003144: ACMI with linear mesh motion and deforming mesh not working properly with velocityComponentLaplacian motion solver
DescriptionThank you, Will, for the improvement for the ACMI implementation (issue ID 0002057). I confirm that the feature now seems to work, when using the velocityComponentLaplacian motion solver. But I could not get my test case to run in parallel with pimpleFoam and MPI (mpirun -np 4 pimpleFoam -parallel). In addition, at least the postProcess utility with -func "mag(U)" did not work correctly. The mag(U) field was zero throughout the time steps.

Attached is a simple and coarse test case for ACMI with linear motion mesh and deforming mesh using the velocityComponentLaplacian motion solver. Decomposing (decomposePar) the case produces errors, e.g.:

Processor 0: field transfer
AMI: Creating addressing and weights between 291 source faces and 0 target faces
--> FOAM Warning :
    From function bool Foam::AMIMethod::initialise(Foam::labelListList&, Foam::scalarListList&, Foam::labelListList&, Foam::scalarListList&, Foam::label&, Foam::label&)
    in file AMIInterpolation/AMIInterpolation/AMIMethod/AMIMethod/AMIMethod.C at line 104
    291 source faces but no target faces
AMI: Patch source sum(weights) min/max/average = 0, 0, 0
...

Running the case in parallel leads to errors, e.g.:

Selecting dynamicFvMesh dynamicMotionSolverFvMesh
AMI: Creating addressing and weights between 378 source faces and 100 target faces
--> FOAM Warning :
    From function bool Foam::AMIMethod::initialise(Foam::labelListList&, Foam::scalarListList&, Foam::labelListList&, Foam::scalarListList&, Foam::label&, Foam::label&)
    in file AMIInterpolation/AMIInterpolation/AMIMethod/AMIMethod/AMIMethod.C at line 104
    291 source faces but no target faces
AMI: Patch source sum(weights) min/max/average = 0, 0, 0
AMI: Patch target sum(weights) min/max/average = 0, 0, 0
Selecting motion solver: velocityComponentLaplacian
[0] [1]
[1]
[1] --> FOAM FATAL IO ERROR:
[1] inconsistent patch and patchField types for
    patch type cyclicACMI and patchField type uniformFixedValue
[1]
[1] file: /<path>/motionVelocityComponentLaplacian/processor1/0.000/cellMotionUz.boundaryField.ACMI_ExhaustIn_couple from line 67 to line 70.
...
Steps To ReproduceTrying to run the case in parallel:
1. Untar the attached test case package.
2. Decompose the case with "decomposePar".
3. Run the case with "mpirun -np 4 pimpleFoam -parallel".

Trying to use the postProcess utility:
1. Untar the attached test case package.
2. Run the case with "pimpleFoam".
3. Run the postProcess utility with "postProcess -func "mag(U)".
Additional InformationRelated to issue ID 0002057
TagsNo tags attached.

Activities

jskortel

2018-12-31 11:45

reporter  

motionVelocityComponentLaplacian.tgz (204,381 bytes)

henry

2018-12-31 12:04

manager   ~0010247

Work on AMI and ACMI requires funding, see

https://openfoam.org/news/funding-2019/
https://openfoam.org/maintenance/

will

2019-01-04 13:38

manager   ~0010251

This was a problem with some of the boundary conditions (in your case, uniformFixedValue) not propagating the patchType entry on decomposition. Fixed in dev by commit 70021b12.

The warning is unrelated. It is warning you that the AMI-s do not overlap at all in their initial locations. I think in your case that this is intended.

Issue History

Date Modified Username Field Change
2018-12-31 11:45 jskortel New Issue
2018-12-31 11:45 jskortel File Added: motionVelocityComponentLaplacian.tgz
2018-12-31 12:04 henry Note Added: 0010247
2019-01-04 13:38 will Assigned To => will
2019-01-04 13:38 will Status new => resolved
2019-01-04 13:38 will Resolution open => fixed
2019-01-04 13:38 will Fixed in Version => dev
2019-01-04 13:38 will Note Added: 0010251