View Issue Details

IDProjectCategoryView StatusLast Update
0003094OpenFOAMBugpublic2019-02-26 16:00
Reportersarathkrishnan11Assigned Tohenry 
Status closedResolutionno change required 
PlatformLinuxOSUbuntuOS Version18.01
Product Version5.0 
Fixed in Version 
Summary0003094: problem with createBaffle updating pointLevel
DescriptionWhile creating cyclic patches using createBaffle, the boundaryfield of the file 0/pointLevel is not updated with the new cyclic patches. Even though it works well in serial with a single processor, it is not working while trying to decompose the case and run in parallel.
Additional Information--> FOAM FATAL IO ERROR:
Cannot find patchField entry for cyclic porous_half0
Is your field uptodate with split cyclics?
Run foamUpgradeCyclics to convert mesh and fields to split cyclics.

file: /home/sarath/OpenFOAM/sarath-5.0/run/case121/0/pointLevel.boundaryField from line 28 to line 36.
TagsNo tags attached.



2018-10-19 09:02

manager   ~0010113

Have you tried version 6 and/or dev? Could you please upload a case which reproduces the problem?


2018-10-19 09:59

reporter   ~0010114

Yes I have tried it on both version 6 and dev-8f3f2f7365c1. The problem exists.
Here is the case files for version 6 or dev

BaffleNet.tar.xz (6,992 bytes)


2018-11-07 08:42

reporter   ~0010149

Is the casefile too big for you just to test, I could make one simple if you need?


2018-11-07 10:39

manager   ~0010150

No, sorry the case file is fine. I can reproduce the problem.

There is no easy way of fixing this. As it stands, your solution is to delete the point fields before running createPatch or set them up with the final set of patches, put them in a separate directory whilst createPatch runs, and then copy them in place after.

The issue is that the createBaffle utility (and fvMeshTools on which it depends) does a manual clear-out and then adds the patches to the mesh in-place. The pointMesh gets destroyed by this operation, which invalidates all the point fields. So, the point fields ca
n't be included in the conversion that the utility does.

Changes like this are supposed to go through the topology engine, which would cause the pointMesh and pointFields to get mapped. The patch addition needs to be rewritten in this framework.

Fixing this is a big job. Are you funding this sort of maintenance work (


2018-11-07 11:09

reporter   ~0010151

Okay. I am using this temporary solution as well.
At the moment, this is not a priority bug for me. And regarding funding for this maintenance work, I worry I can not since I am a student learning OpenFOAM (Not using it for business purposes). But I feel sorry to say this.
Thank you for your time and hope it would be fixed sometime in future.


2019-02-26 16:00

manager   ~0010334

Currently createBaffles does not manipulate the pointMesh or pointFields but even if it did the case provided has field handing switched-off in the createBafflesDict so either way the pointLevel field in the 0 directory would be inconsistent with the final mesh. The best general solution to this problem is to set snappyHexMesh to not write the pointLevel file, which is now the default:

// Write flags
    // scalarLevels // Do not write the pointLevel field

If the pointLevel field file is needed for diagnostics it should be deleted before createBaffles or other mesh manipulations are run.

Issue History

Date Modified Username Field Change
2018-10-18 15:25 sarathkrishnan11 New Issue
2018-10-19 09:02 will Note Added: 0010113
2018-10-19 09:59 sarathkrishnan11 File Added: BaffleNet.tar.xz
2018-10-19 09:59 sarathkrishnan11 Note Added: 0010114
2018-11-07 08:42 sarathkrishnan11 Note Added: 0010149
2018-11-07 10:39 will Note Added: 0010150
2018-11-07 11:09 sarathkrishnan11 Note Added: 0010151
2019-02-26 16:00 henry Assigned To => henry
2019-02-26 16:00 henry Status new => closed
2019-02-26 16:00 henry Resolution open => no change required
2019-02-26 16:00 henry Note Added: 0010334