View Issue Details

IDProjectCategoryView StatusLast Update
0000306OpenFOAM[All Projects] Bugpublic2011-10-05 10:27
Reporteruser266Assigned Touser2 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSOpenSuseOS Version11.2
Product Version 
Fixed in Version 
Summary0000306: libforces not producing output
DescriptionDear support,

I am using libforces to evaluate forces acting on a surface. Unfortunately, the forces.dat output file is empty apart from the first line:

# Time forces(pressure, viscous) moment(pressure, viscous) local forces(pressure, viscous) local moment(pressure, viscous)

This error first sprung up after updating to the latest Version of 2.0.x via git yesterday (04/10/2011)
Additional InformationrhoPimpleFoam

serial and parallel

same case works on older 2.0.x
TagsNo tags attached.

Activities

user266

2011-10-05 09:43

  ~0000681

[correction]: The forces.dat file actually reads

# Time forces(pressure, viscous) moment(pressure, viscous)

the local terms seem to be missing

user2

2011-10-05 09:54

  ~0000682

I've just been testing a couple of tutorials, and have not managed to recreate your reported error. Have you set 'log false'?

Re: local forces - the behaviour has been updated: local forces are now only output if you specify a local co-ordinate system

user266

2011-10-05 10:00

  ~0000683

I was previously using libforces without any mention of "log" at all. It seems this is no longer possible.

I have added "log true;" and it seems to be working fine. forces are even output directly by the solver which is rather neat.

Thank you for your assistance!!

user2

2011-10-05 10:27

  ~0000684

The behaviour of 'log' was a little misleading - I've pushed a fix under commit 0e9761798d2e6 whereby values are always written to file, but only to the screen if 'log true'

Issue History

Date Modified Username Field Change
2011-10-05 09:23 user266 New Issue
2011-10-05 09:43 user266 Note Added: 0000681
2011-10-05 09:54 user2 Note Added: 0000682
2011-10-05 10:00 user266 Note Added: 0000683
2011-10-05 10:27 user2 Note Added: 0000684
2011-10-05 10:27 user2 Status new => resolved
2011-10-05 10:27 user2 Fixed in Version => 2.0.x
2011-10-05 10:27 user2 Resolution open => fixed
2011-10-05 10:27 user2 Assigned To => user2