View Issue Details

IDProjectCategoryView StatusLast Update
0002835OpenFOAMBugpublic2018-02-13 16:53
ReporterJoris.C Assigned Tohenry  
Status resolvedResolutionfixed 
Fixed in Versiondev 
Summary0002835: decomposePar -force fails to remove time folders in processor* dirs
DescriptionWhen I have a case which has already run in parallel, and thus a time folder (eg 0.156) in the processor-subdirs, running decomposePar on the case (with only a 0 time folder) fails to remove these time folders.

The specific commands I am runnning:
decomposePar -case xx -force -allRegions
decomposePar -case xx -region yy -force

Neither of them remove this time folder.

Also when I change the number of processors, it fails to remove this time folder and/or processor dirs (when I lower the number of processors).
Steps To ReproduceRun a case in parallel and have it write a time, decompose again afterwards.
Additional InformationIt seems to me this was introduced by v5.
TagsNo tags attached.



2018-02-08 11:17

manager   ~0009280

I ran the cavity case in parallel on 2 processors and then changed the numberOfSubdomains to 4 and ran

decomposePar -force

and it worked fine and the case ran fine on 4 processors.

Could you provide the steps to reproduce the problem on one of the tutorial cases?


2018-02-08 11:18

manager   ~0009281

I ran the case on 4 processors then reset the numberOfSubdomains to 2 and ran

decomposePar -force

and it worked fine and the case ran fine on 2 processors.


2018-02-08 12:22

reporter   ~0009283

1) Run OpenFOAM-5.x/tutorials/heatTransfer/chtMultiRegionFoam/multiRegionHeater with ./Allrun
2) Interrupt
3) Check whether there is a time folder in processor0 (for me it was 10) and none in the case folder itself (for me it has reconstructed, but I removed it manually)
4) decomposePar -allRegions -force, which should decompose time 0
5) Time folder 10 is still in processor folder

Giving that it works fine for the cavity case, it is probably connected to the allRegions argument.


2018-02-13 10:31

manager   ~0009308

Currently forced removal of the previous decomposition is disallowed for specified region and all regions:

            if (region || allRegions)
                procDirsProblem = false;
                forceOverwrite = false;

It is not clear why this should be disallowed is it is a command line option and need not be specified if not needed. I will run some tests.


2018-02-13 16:53

manager   ~0009310

commit 6a417d4a931f406e6e2875135134def052ee6763

Note that this adds support for -force with -allRegions but for -region which would be more complicated as it requires seaching the processor directory trees for region sub-directories.

Issue History

Date Modified Username Field Change
2018-02-08 10:50 Joris.C New Issue
2018-02-08 11:17 henry Note Added: 0009280
2018-02-08 11:18 henry Note Added: 0009281
2018-02-08 12:22 Joris.C Note Added: 0009283
2018-02-13 10:31 henry Note Added: 0009308
2018-02-13 16:53 henry Assigned To => henry
2018-02-13 16:53 henry Status new => resolved
2018-02-13 16:53 henry Resolution open => fixed
2018-02-13 16:53 henry Fixed in Version => dev
2018-02-13 16:53 henry Note Added: 0009310