View Issue Details

IDProjectCategoryView StatusLast Update
0002832OpenFOAM[All Projects] Bugpublic2019-04-25 09:14
ReporterjkauAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version14.04 LTS
Product Versiondev 
Fixed in Versiondev 
Summary0002832: interFoam: unstable when restarting a reconstructed case
DescriptionWhen restarting an interFoam case in serial after reconstructing a parallel run, the restart is not smooth. Same, when the reconstructed case is again decomposed again, and restarted in parallel. One can see this in the min/max alpha-values, and also forces a oscillating quite remarkable.
If the face velocity field Uf is deleted, the re-start is smooth.
Steps To Reproduce1. Run DTCHullMoving tutorial for a short time (e.g. 0.1 s).
2. Reconstruct
3. Run in serial
4. Plot forces
TagsinterFoam

Activities

henry

2018-02-07 12:08

manager   ~0009269

Does this problem only occur when restarting a reconstructed case or also when restarting a parallel run or a serial run?

henry

2018-02-07 12:21

manager   ~0009270

The issue is reconstructPar treating all surface fields as fluxes and setting the sign according to the face orientation.

jkau

2018-02-07 13:15

reporter   ~0009271

Only occures when restarting a reconstructed case. Is there any need for storing Uf?

henry

2018-02-07 13:36

manager   ~0009272

> Is there any need for storing Uf?

Same as phi in the static mesh case; formally these are needed to get an accurate restart but not critical.

henry

2019-04-01 22:58

manager   ~0010403

Resolved by commit 44742d235eb02d916d83ba46212c95cdb86268a7

Issue History

Date Modified Username Field Change
2018-02-07 10:53 jkau New Issue
2018-02-07 11:06 jkau Tag Attached: interFoam
2018-02-07 12:08 henry Note Added: 0009269
2018-02-07 12:21 henry Note Added: 0009270
2018-02-07 13:15 jkau Note Added: 0009271
2018-02-07 13:36 henry Note Added: 0009272
2019-04-01 22:58 henry Assigned To => henry
2019-04-01 22:58 henry Status new => resolved
2019-04-01 22:58 henry Resolution open => fixed
2019-04-01 22:58 henry Fixed in Version => dev
2019-04-01 22:58 henry Note Added: 0010403