View Issue Details

IDProjectCategoryView StatusLast Update
0000275OpenFOAM[All Projects] Bugpublic2012-05-31 16:14
Reporteruser19Assigned Touser2 
PrioritynormalSeveritymajorReproducibilityN/A
Status resolvedResolutionno change required 
Product Version 
Fixed in Version 
Summary0000275: The UserGuide and the ProgrammersGuide are not available in a transparent format
DescriptionThe GFDL under which the UserGuide and the ProgrammersGuide are distributed requires that the documentation be made available in a "transparent" format. Citing from the GFDL:

===============================
A "Transparent" copy of the Document means a machine-readable copy, represented in a format whose specification is available to the general public, that is suitable for revising the document straightforwardly with generic text editors or (for images composed of pixels) generic paint programs or (for drawings) some widely available drawing editor, and that is suitable for input to text formatters or for automatic translation to a variety of formats suitable for input to text formatters. A copy made in an otherwise Transparent file format whose markup, or absence of markup, has been arranged to thwart or discourage subsequent modification by readers is not Transparent. An image format is not Transparent if used for any substantial amount of text. A copy that is not "Transparent" is called "Opaque".

Examples of suitable formats for Transparent copies include plain ASCII without markup, Texinfo input format, LaTeX input format, SGML or XML using a publicly available DTD, and standard-conforming simple HTML, PostScript or PDF designed for human modification. Examples of transparent image formats include PNG, XCF and JPG. Opaque formats include proprietary formats that can be read and edited only by proprietary word processors, SGML or XML for which the DTD and/or processing tools are not generally available, and the machine-generated HTML, PostScript or PDF produced by some word processors for output purposes only.
===============================

The PDF's distributed with the OpenFOAM sources are not "designed for human modification", they are to be considered opaque. Since no transparent format is available, OpenCFD clearly violates the GFDL under which it licenses above mentioned documents.
TagsNo tags attached.

Activities

wyldckat

2012-01-15 17:54

updater   ~0000922

I was reviewing this subject due to a brief discussion on the forum. Upon briefly analyzing the GFDL license and the provided PDF files, it feels that these PDF files fall in a very "grey" area:
 * The text provided in them can be easily copied and pasted or simply extracted without the need for OCR software. On the other hand, truly opaque PDF files provide the whole content in image format only (or sectioned image blobs) and sometimes it has locks on them to avoid printing or "copy-pasting".
 * It can be edited with PDFEdit: http://sourceforge.net/projects/pdfedit/ - well, at least for small typos it works... sort-of...
 * Images can also be easily extracted with the proper open source tools. I've done this before with another document, so I'll have to look it up again.

In other words, replicating these documents in a open format shouldn't take more a couple of hours of tinkering for unformatted text and image output and, perhaps, no more than a weekend with full formatting.
Therefore, I think it's arguable if the provided format is in fact opaque or not.

user19

2012-05-31 10:11

  ~0001348

As the license of these documents has been recently changed to CC-by-NC-ND, I consider this issue to be resolved.

Issue History

Date Modified Username Field Change
2011-08-11 05:38 user19 New Issue
2012-01-15 17:54 wyldckat Note Added: 0000922
2012-05-31 10:11 user19 Note Added: 0001348
2012-05-31 16:14 user2 Status new => resolved
2012-05-31 16:14 user2 Resolution open => no change required
2012-05-31 16:14 user2 Assigned To => user2