View Issue Details

IDProjectCategoryView StatusLast Update
0002539OpenFOAM[All Projects] Bugpublic2017-05-15 14:41
ReporterStephanGAssigned Tohenry 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version14.04
Product Versiondev 
Fixed in Version 
Summary0002539: wallHeatFlux functionObject in solid regions
DescriptionThe new wall heat flux function object does not work in solid regions. The fluid version is not effected and works. This is due the fact that the heat flux or alphaEff is calculated with the compressible turbulenceModel within wallHeatFlux.C.
Steps To ReproducechtMultiRegionSimpleFoam Tutorial Case with added function object
functions
{
    wallHeatFluxSolid
    {
        libs ("libfieldFunctionObjects.so");
        type wallHeatFlux;
    region rightSolid;
        writeControl timeStep;
    executeControl writeTime;
    }
}

will result in:

--> FOAM FATAL ERROR:
Unable to find compressible turbulence model in the database

    From function virtual bool Foam::functionObjects::wallHeatFlux::execute()
    in file wallHeatFlux/wallHeatFlux.C at line 224.

FOAM exiting

Changing the region to a fluid one will work however.
TagschtMultiregionFoam

Activities

henry

2017-05-04 16:18

manager   ~0008091

> wallHeatFlux functionObject in solid regions

Correct, it does not have this functionality. Can you provide a patch which adds this functionality?

StephanG

2017-05-05 07:37

reporter   ~0008096

I have to look into it. From my perspective the only necessary change is to add solidThermo.H and switch to calculating alpha with it if necessary (turbulence not valid). This seems to be the way it was done in 3.0 and 4.0.

StephanG

2017-05-06 21:51

reporter   ~0008107

Attached is a simple change to incorporate solid regions. Tested with chtMultiRegionSimpleFoam. I have not tested if this produces an issue with anisotropic alphas.
Possible extensions might include adding support for incompressible solvers with a passive scalar equation. Adding the option to specify the conductivity and temperature fields might be an option. I am not sure though if that is necessary or wished for. An option to output the radiative qr flux separately might also be handy to some users, since this was possible in 4.x. Having the option to output the heatflux field at another intervall than the log interval might be handy as well.

wallHeatFluxChanged.tar.gz (4,184 bytes)

henry

2017-05-15 14:41

manager   ~0008148

Thanks for the patch.

Resolved by commit 56283c39e51c9db8807136cae71adfc33524c340

Issue History

Date Modified Username Field Change
2017-05-04 16:07 StephanG New Issue
2017-05-04 16:07 StephanG Tag Attached: chtMultiregionFoam
2017-05-04 16:18 henry Note Added: 0008091
2017-05-04 16:22 henry Severity minor => feature
2017-05-05 07:37 StephanG Note Added: 0008096
2017-05-06 21:51 StephanG File Added: wallHeatFluxChanged.tar.gz
2017-05-06 21:51 StephanG Note Added: 0008107
2017-05-15 14:41 henry Assigned To => henry
2017-05-15 14:41 henry Status new => resolved
2017-05-15 14:41 henry Resolution open => fixed
2017-05-15 14:41 henry Note Added: 0008148