View Issue Details

IDProjectCategoryView StatusLast Update
0002489OpenFOAM[All Projects] Bugpublic2017-03-10 08:19
Reporterjavad1360Assigned Tohenry 
PriorityurgentSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOSOtherOS Version(please specify)
Product Version 
Fixed in Version 
Summary0002489: DynamicLagrangian LES model doesnt work in sprayFoam In Lagrangian-Tutorials
DescriptionMy Problem is : 1- I have openfoam v3+ on my labtop. I have applied DynamicLagrangian LES model with solver : sprayFoam and it works well without problem

2- I have installed openfoam 4 from your website On my PC and i tried to run the above mentioned code in this new version on my PC..it doesn't work and gives me this error :
------------------------------

FOAM FATAL ERROR:
incompatible dimensions for operation
    [flm[0 4 -5 0 0 0 0] ] + [flm[1 1 -5 0 0 0 0] ]

    From function checkMethod(const fvMatrix<Type>&, const fvMatrix<Type>&)
    in file /mnt/home/SW/CFDSupportFOAM4.0 /OpenFOAM-3.0.x/src/finiteVolu me/lnInclude/fvMatrix.C at line 1295.

TagssprayFoam, turbulence models

Activities

henry

2017-03-09 07:37

manager   ~0007869

Could you please provide details on how this problem can be reproduced? Without this information it is difficult for anyone to help.

henry

2017-03-09 09:47

manager   ~0007870

I had a quick look at the code and found a potential problem with the volumetric flux and corrected it in OpenFOAM-4.x: commit fc009a4fa2569c74f8f9bdb31152c4b023974939 but you will have to test it yourself because you did not provide a test case which reproduces the problem.

javad1360

2017-03-10 07:23

reporter   ~0007893

In order to find my isssue, please try to apply Danyamiclagrangian LES mODEL at this address: tutorial-lagrangian-sprayFoam-aaccbomb

henry

2017-03-10 08:00

manager   ~0007894

The tutorial-lagrangian-sprayFoam-aaccbomb tutorial is not setup to run with the
"Danyamiclagrangian" model. I assume that you have now set it up to run with this model and it would save a lot of time if you provided that setup rather than expect anyone who might wish to help you repeat your work. Additionally this would allow for your setup to be checked in case the bug is there rather than in the model.

henry

2017-03-10 08:19

manager   ~0007895

I believe this issue is now resolved. Please reopen if the problem persists.

Resolved in OpenFOAM-dev by commit a600a2c91a1ba62dd9034715f816fd62aa7179a7

Resolved in OpenFOAM-4.x by commit fc009a4fa2569c74f8f9bdb31152c4b023974939

Issue History

Date Modified Username Field Change
2017-03-09 02:01 javad1360 New Issue
2017-03-09 02:01 javad1360 Tag Attached: sprayFoam
2017-03-09 02:01 javad1360 Tag Attached: turbulence models
2017-03-09 07:37 henry Note Added: 0007869
2017-03-09 09:47 henry Note Added: 0007870
2017-03-10 07:23 javad1360 Note Added: 0007893
2017-03-10 08:00 henry Note Added: 0007894
2017-03-10 08:19 henry Assigned To => henry
2017-03-10 08:19 henry Status new => resolved
2017-03-10 08:19 henry Resolution open => fixed
2017-03-10 08:19 henry Note Added: 0007895