View Issue Details

IDProjectCategoryView StatusLast Update
0002350OpenFOAM[All Projects] Bugpublic2016-12-01 15:58
ReporterchrisAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version14.04
Product Version 
Fixed in Version 
Summary0002350: Creating a field that is cache-able with postProcess fails
DescriptionThe "grad(U)" function for postProcess throws out warnings when it attempts to calculate for more than one time directory, e.g.

Executing functionObjects
--> FOAM Warning :
    From function bool Foam::functionObjects::regionFunctionObject::store(Foam::word&, const Foam::tmp<T>&, bool) [with ObjectType = Foam::GeometricField<Foam::Tensor<double>, Foam::fvPatchField, Foam::volMesh>]
    in file /home/ubuntu/OpenFOAM/OpenFOAM-4.1/src/OpenFOAM/lnInclude/regionFunctionObjectTemplates.C at line 61
    Cannot store cache-able field with the named used in the cache.
    Either choose a different name or cache the field and use the 'writeObjects' functionObject.
--> FOAM Warning : functionObject grad: Cannot find required field U
Steps To Reproducerun
cp -r $FOAM_TUTORIALS/incompressible/simpleFoam/pitzDaily .
blockMesh
simpleFoam
postProcess -func "grad(U)"
TagsNo tags attached.

Activities

henry

2016-11-24 22:36

manager   ~0007323

Currently the 'grad' functionObject can only be used if the result is explicitly named differently to the default due to interference between the caching of gradients and the post-processing fields.

I am testing a work-around for this in OpenFOAM-dev.

henry

2016-11-24 23:10

manager   ~0007324

This issue should be resolved by commit c0a950c5c678b4a47e749a201527fc566f849be8 in OpenFOAM-dev but more testing is needed befor committing it to OpenFOAM-4.x.

henry

2016-12-01 15:58

manager   ~0007370

Resolved in OpenFOAM-4.x by commit 0e18bbaa125228dd9f7a227dee7d642f9ecfc453

Resolved in OpenFOAM-dev by commit c0a950c5c678b4a47e749a201527fc566f849be8

Issue History

Date Modified Username Field Change
2016-11-24 20:22 chris New Issue
2016-11-24 22:36 henry Note Added: 0007323
2016-11-24 23:10 henry Note Added: 0007324
2016-12-01 15:58 henry Assigned To => henry
2016-12-01 15:58 henry Status new => resolved
2016-12-01 15:58 henry Resolution open => fixed
2016-12-01 15:58 henry Fixed in Version => 4.x
2016-12-01 15:58 henry Note Added: 0007370