View Issue Details

IDProjectCategoryView StatusLast Update
0002293OpenFOAM[All Projects] Bugpublic2016-11-05 15:09
ReporterwyldckatAssigned Tohenry 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0002293: Source code packages for 4.1 have the wrong version defined in etc/bashrc and etc/cshrc
DescriptionSince technically the source code tarballs are being downloaded straight from Github: https://github.com/OpenFOAM/OpenFOAM-4.x/releases/tag/version-4.1 - this means that a commit is missing where the version number is adjusted.

Here are the commands that fix this automatically, at least for the most part:

   sed -i -e 's=4\.x=4.1=' etc/bashrc etc/cshrc
   git add -u
   git commit -m "Set version for the 4.1 release"
   git tag -f version-4.1
   git revert HEAD
Additional InformationI didn't spot this myself at first, I spotted this because of the report made here: http://www.cfd-online.com/Forums/openfoam-installation/178732-bashrc-file-problem.html
TagsNo tags attached.

Activities

henry

2016-10-16 15:14

manager   ~0007014

Thanks for reporting and providing the commands to fix; I have applied them.

wyldckat

2016-10-17 10:08

updater   ~0007015

Sorry, I had to re-open this report, because the changes haven't been pushed yet to the public repository :(

I forgot to write about the explicit instructions, because I got lost on the work-flow for the commands, given that I didn't know if you were only using a single repository alias in your git repository.

So, to complete the train of thought, if the alias is named "origin" for the 4.x repository, then the following commands should work as intended:

  git push origin master
  git push origin version-4.1 -f

henry

2016-10-17 10:34

manager   ~0007016

Done

wyldckat

2016-10-17 10:37

updater   ~0007017

Many thanks!

wyldckat

2016-11-05 15:08

updater   ~0007094

Sorry, just re-opening to try and close it with status "resolved".

Issue History

Date Modified Username Field Change
2016-10-16 14:42 wyldckat New Issue
2016-10-16 14:42 wyldckat Status new => assigned
2016-10-16 14:42 wyldckat Assigned To => henry
2016-10-16 15:14 henry Status assigned => resolved
2016-10-16 15:14 henry Resolution open => fixed
2016-10-16 15:14 henry Fixed in Version => 4.1
2016-10-16 15:14 henry Note Added: 0007014
2016-10-17 10:08 wyldckat Status resolved => feedback
2016-10-17 10:08 wyldckat Resolution fixed => reopened
2016-10-17 10:08 wyldckat Note Added: 0007015
2016-10-17 10:34 henry Note Added: 0007016
2016-10-17 10:37 wyldckat Status feedback => assigned
2016-10-17 10:37 wyldckat Resolution reopened => fixed
2016-10-17 10:37 wyldckat Note Added: 0007017
2016-10-17 10:38 wyldckat Status assigned => closed
2016-11-05 15:08 wyldckat Status closed => feedback
2016-11-05 15:08 wyldckat Resolution fixed => reopened
2016-11-05 15:08 wyldckat Note Added: 0007094
2016-11-05 15:09 wyldckat Status feedback => resolved
2016-11-05 15:09 wyldckat Resolution reopened => fixed