View Issue Details

IDProjectCategoryView StatusLast Update
0002249OpenFOAM[All Projects] Bugpublic2016-09-20 07:40
ReporterelisabetAssigned Tohenry 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionno change required 
PlatformGNU/LinuxOSUbuntuOS Version14.04
Product Versiondev 
Fixed in Version 
Summary0002249: Reconstruct problem for Qro scalarField with libs in controlDict
DescriptionVersion OF-plus from 13 July 2016 (plus-5d9038294daa).

I need to add a new radiation library to controlDict file. But even if I add the original libradiationModels.so this problem appears:

When the volScalarField Qr is reconstructed, the scalarField Qro is filled with non-zero values despite its original value is 'uniform 0'.
Steps To Reproduceextract files from possibleBugReconstruct.tar.gz
./Allrun-parallel
reconstructPar -allRegions -time 10
vim 10/left/Qr (and check for Qro field)
Additional Information
If no library is included in controlDict file, this error does not appear.

If I add the library but without the NamedEnum definition (and proper .C modifications) in file submodels/boundaryRadiationProperties/boundaryRadiationPropertiesPatch.C, this problem does not appear.
TagsNo tags attached.

Activities

elisabet

2016-09-19 12:58

reporter  

possibleBugReconstruct.tar.gz (17,989 bytes)

henry

2016-09-19 13:19

manager   ~0006875

OpenFOAM+ is a fork of OpenFOAM not released or maintained by the OpenFOAM Foundation.

Please upgrade to OpenFOAM-4.0/x or OpenFOAM-dev.

elisabet

2016-09-19 13:23

reporter   ~0006876

I indicated 'crash' only because paraFoam crashes due to the presence of nan in Qro, but reconstructPar does not crashes.

henry

2016-09-19 13:27

manager   ~0006877

OpenFOAM+ is a fork of OpenFOAM not released or maintained by the OpenFOAM Foundation.

Please upgrade to OpenFOAM-4.0/x or OpenFOAM-dev.

elisabet

2016-09-20 02:33

reporter   ~0006878

Sorry, in OF-dev the error does not appear.

Issue History

Date Modified Username Field Change
2016-09-19 12:58 elisabet New Issue
2016-09-19 12:58 elisabet File Added: possibleBugReconstruct.tar.gz
2016-09-19 13:19 henry Assigned To => henry
2016-09-19 13:19 henry Status new => closed
2016-09-19 13:19 henry Resolution open => no change required
2016-09-19 13:19 henry Note Added: 0006875
2016-09-19 13:23 elisabet Status closed => feedback
2016-09-19 13:23 elisabet Resolution no change required => reopened
2016-09-19 13:23 elisabet Note Added: 0006876
2016-09-19 13:27 henry Status feedback => closed
2016-09-19 13:27 henry Resolution reopened => no change required
2016-09-19 13:27 henry Note Added: 0006877
2016-09-20 02:33 elisabet Status closed => feedback
2016-09-20 02:33 elisabet Resolution no change required => reopened
2016-09-20 02:33 elisabet Note Added: 0006878
2016-09-20 07:40 henry Status feedback => resolved
2016-09-20 07:40 henry Resolution reopened => no change required
2016-09-20 07:40 henry Fixed in Version => 4.x