View Issue Details

IDProjectCategoryView StatusLast Update
0002104OpenFOAM[All Projects] Bugpublic2016-05-29 22:32
ReporteralexeymAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versiondev 
Fixed in Version 
Summary0002104: Inconsistent time stepping in buoyantBoussinesqPimpleFoam
DescriptionMain solver loop uses runTime.loop() for time stepping (https://github.com/OpenFOAM/OpenFOAM-dev/blob/master/applications/solvers/heatTransfer/buoyantBoussinesqPimpleFoam/buoyantBoussinesqPimpleFoam.C#L78), but before PIMPLE loop setDeltaT.H is included (https://github.com/OpenFOAM/OpenFOAM-dev/blob/master/applications/solvers/heatTransfer/buoyantBoussinesqPimpleFoam/buoyantBoussinesqPimpleFoam.C#L84), so PIMPLE loop is performed with time step that could differ from one used in runTime.loop().

Use runTime.run() in while loop and increase runTime after setting new time step (just like in other PIMPLE-family solvers).
Steps To ReproduceRun hotRoom tutorial case with adjustTimeStep set to yes.
Additional InformationReport is for dev, yet the problem is in all versions (up to 2.0.x).
TagsNo tags attached.

Activities

henry

2016-05-29 22:31

manager   ~0006330

Thanks for reporting

Resolved in OpenFOAM-3.0.x by commit 398edf4774c39c43cc1ab2ad78cba7b545c36a09
Resolved in OpenFOAM-dev by commit 5af2515f870207405a2149ee827fcd89aa431db8

Issue History

Date Modified Username Field Change
2016-05-29 13:54 alexeym New Issue
2016-05-29 22:31 henry Note Added: 0006330
2016-05-29 22:31 henry Status new => resolved
2016-05-29 22:31 henry Fixed in Version => 3.0.x
2016-05-29 22:31 henry Resolution open => fixed
2016-05-29 22:31 henry Assigned To => henry