View Issue Details

IDProjectCategoryView StatusLast Update
0002082OpenFOAM[All Projects] Bugpublic2016-05-31 17:22
ReporterbrdvoldeAssigned Tohenry 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version14.04
Product Versiondev 
Fixed in Versiondev 
Summary0002082: AMI + dynamic mesh + 6 DoF
DescriptionTwo cases are provided to simulate a floating object which is pushed a bit down and released. The motion should follow a damped oscillatory motion

The first case uses the laplacian solver to calculate the mesh deformation. This method is able to simulate more than one uncoupled floating body.
The second case uses the new SLERP interpolation method which is only valid for one floating object.

To limit mesh deformation around the interface, AMIs can be used.
However, in case the laplacian solver is used, the mesh deformation goes trough the AMI.
While in case SLERP is used, the mesh deformation satisfies the boundary conditions at the AMI (moving mesh: slip, fixed mesh: fixedValue). But, if the number of cores is changes (e.g. from 3 to 2), the deformation can possible go trough the AMI as well

The layout for ParaView is also available: floatingBlock_AMI_compare.pvsm
Steps To ReproduceGo into the directory of a case.
Execute "runCase" to start the simulation.
TagsNo tags attached.

Relationships

duplicate of 0002057 resolvedhenry ACMI incompatible with velocityComponentLaplacian 

Activities

brdvolde

2016-05-04 10:44

reporter  

AMI-dynMesh-6DoF.tar.gz (40,446 bytes)

Issue History

Date Modified Username Field Change
2016-05-04 10:44 brdvolde New Issue
2016-05-04 10:44 brdvolde File Added: AMI-dynMesh-6DoF.tar.gz
2016-05-04 11:03 henry Priority high => normal
2016-05-04 11:03 henry Severity major => feature
2016-05-04 11:03 henry Product Version 3.0.x => dev
2016-05-04 11:03 henry Relationship added duplicate of 0002057
2016-05-31 17:22 henry Status new => resolved
2016-05-31 17:22 henry Fixed in Version => dev
2016-05-31 17:22 henry Resolution open => fixed
2016-05-31 17:22 henry Assigned To => henry