View Issue Details

IDProjectCategoryView StatusLast Update
0002052OpenFOAMPatchpublic2016-04-16 18:45
ReporterjurichAssigned Tohenry 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version14.04
Product Versiondev 
Fixed in Version 
Summary0002052: Incomplete implementation of QrPrevious_ in externalWallHeatFluxTemperatureFvPatchScalarField.C
DescriptionThe QrPrevious_ field isn't fully implemented, so it doesn't correctly map when using reconstructPar. The following changes fixed the issue for me (in externalWallHeatFluxTemperatureFvPatchScalarField.C): (a) line 73 change to: QrPrevious_(p.size(),0.0), (b) add QrPrevious_.autoMap(m); after line 230 and (c) add QrPrevious_.rmap(tiptf.QrPrevious_, addr); after line 247.
TagsNo tags attached.

Activities

wyldckat

2016-04-16 16:06

updater  

externalWallHeatFluxTemperatureFvPatchScalarField.C (10,634 bytes)

wyldckat

2016-04-16 16:06

updater  

externalWallHeatFluxTemperatureFvPatchScalarField.H (8,122 bytes)

wyldckat

2016-04-16 16:12

updater   ~0006127

@Jurich: Many thanks for the report! The changes are consistent with what's done with the sibling field variables, therefore I only made the changes and tested if it built.

If you could provide a modified tutorial case from OpenFOAM to use this boundary condition, it would be great for ensuring that this doesn't happen again in the future (in case this boundary condition gets new features).


@Henry: Attached at the files with the fixes that Jurich proposed, which make perfect sense given that it's a scalar field like the sibling variables "q_", "h_" and "Ta_".

The files are meant for the folder "src/TurbulenceModels/compressible/turbulentFluidThermoModels/derivedFvPatchFields/externalWallHeatFluxTemperature/".

I also updated a little bit the description in the header file, to make it consistent with the other "turbulentTemperature*" classes for which I had provided updates some weeks ago, because all of them derive from "temperatureCoupledBase".

henry

2016-04-16 18:45

manager   ~0006129

Thanks

Resolved by commit eda27b9e7513f33117ddc3ec0ae8b5d4c649fcb7

Issue History

Date Modified Username Field Change
2016-04-15 20:34 jurich New Issue
2016-04-16 16:06 wyldckat File Added: externalWallHeatFluxTemperatureFvPatchScalarField.C
2016-04-16 16:06 wyldckat File Added: externalWallHeatFluxTemperatureFvPatchScalarField.H
2016-04-16 16:12 wyldckat Note Added: 0006127
2016-04-16 16:13 wyldckat Assigned To => henry
2016-04-16 16:13 wyldckat Status new => assigned
2016-04-16 18:45 henry Note Added: 0006129
2016-04-16 18:45 henry Status assigned => resolved
2016-04-16 18:45 henry Resolution open => fixed