View Issue Details

IDProjectCategoryView StatusLast Update
0000203OpenFOAM[All Projects] Bugpublic2011-05-26 09:29
Reporteruser191Assigned Touser21 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSOpenSuseOS Version11.1
Product Version 
Fixed in Version 
Summary0000203: Psas term in SST SAS model
DescriptionThe Psas term in the SST SAS model is presented as

FSAS_
00397 *max
00398 (
00399 dimensionedScalar("zero",dimensionSet(0, 0 , -2, 0, 0),0. ),
00400 zetaTilda2_*kappa_*S2*(L/Lvk2(S2))
00401 - 2.0/alphaPhi_*k_*grad_omega_k
00402 )
00403 );

in Openfoam. But in the reference given (DESIDER-Menter, Egorov), the (L/Lvk2(S2) term is squared (page 55).
TagsNo tags attached.

Activities

user21

2011-05-25 11:15

  ~0000394

We followed the paper referred in the header file. If you can provide with
a newer reference where the term is updated we can proceed to replace it.
Regards

user191

2011-05-25 15:45

  ~0000398

If you see Pg 55, eqn 7 of the reference

(http://books.google.com/books?id=35LZXKc1RLsC&pg=PA51&lpg=PA51&dq=%22Formulation+of+the+Scale-Adaptive+Simulation+%28SAS%29+Model+during+the+DESIDER+Project%22&source=bl&ots=PgDK5PkV4A&sig=eTbkq7w-ZiYoki-ZanwA9cfONIE&hl=en&ei=3SHMTYf1G8Lo0QHy7IjRBg&sa=X&oi=book_result&ct=result&resnum=1&ved=0CBYQ6AEwAA#v=onepage&q=%22Formulation%20of%20the%20Scale-Adaptive%20Simulation%20%28SAS%29%20Model%20during%20the%20DESIDER%20Project%22&f=false)

You can see that it should be sqr((L/Lvk2(S2)) in line 0400 of the code mentioned previously.

user21

2011-05-25 16:53

  ~0000399

We found for this particular term different expressions from different sources.

The present book dates from the same date as our referenced paper. For the time being we are going to follow the reference cited in our source code.

Thanks

user191

2011-05-25 17:25

  ~0000400

Class
00025 Foam::LESmodels::kOmegaSSTSAS
00026
00027 Description
00028 kOmegaSSTSAS LES turbulence model for incompressible flows
00029
00030 Reference:
00031 DESider A European Effort on Hybrid RANS-LES Modelling:
00032 Results of the European-Union Funded Project, 2004 - 2007
00033 (Notes on Numerical Fluid Mechanics and Multidisciplinary Design).
00034 Chapter 8 Formulation of the Scale-Adaptive Simulation (SAS) Model during
00035 the DESIDER Project.
00036 F. R. Menter and Y. Egorov.
00037

So, the link I gave is exactly the same reference. I couldn't get what you meant by "The present book dates from the same date as our referenced paper". This is the same paper only. Please let me know what you think.

user21

2011-05-25 18:53

  ~0000401

In the implementation, we followed :

A Scale-Adaptive Simulation Model using Two-Equation Models
    AIAA 2005-1095
    F. R. Menter and Y. Egorov

And

Evaluation of the SST-SAS model: Channel flow, asymmetric diffuser and axi-
    symmetric hill
    European Conference on Computational Fluid Dynamics
    ECCOMAS CFD 2006
    Lars Davison

Where the term is not squared.

The reference:

DESider A European Effort on Hybrid RANS-LES Modelling:
    Results of the European-Union Funded Project, 2004 - 2007
    (Notes on Numerical Fluid Mechanics and Multidisciplinary Design).
    Chapter 8 Formulation of the Scale-Adaptive Simulation (SAS) Model during
    the DESIDER Project.
    F. R. Menter and Y. Egorov

has the same term squared.
Is the "DESider" report available to investigate the references used there?

user191

2011-05-25 19:32

  ~0000402

I don't have a proper copy of the DESider report, and it doesn't seem that it has references, because its an original report presenting the actual study by Menter and Egorov. It has been published in 2009, years later than the references you mentioned. And BTW, in the header file, these reference weren't mentioned. Do you have any estimate of the differences in the results with and without the squared terms?

user191

2011-05-25 19:47

  ~0000403

In the formulation present in ANSYS the formulation is done with the squared term, which you can see from the presentation of Menter and Egorov for Ansys (2007) of the SST SAS model.

user21

2011-05-26 09:29

  ~0000410

All right. The DESider authors are Menter and Egorov and the publication date is 2009. Then I'll update to coefficient and reference to this reference.

Thanks

Issue History

Date Modified Username Field Change
2011-05-23 21:52 user191 New Issue
2011-05-25 11:11 user21 Assigned To => user21
2011-05-25 11:11 user21 Status new => assigned
2011-05-25 11:15 user21 Note Added: 0000394
2011-05-25 15:45 user191 Note Added: 0000398
2011-05-25 16:53 user21 Note Added: 0000399
2011-05-25 16:53 user21 Status assigned => closed
2011-05-25 16:53 user21 Resolution open => fixed
2011-05-25 17:25 user191 Note Added: 0000400
2011-05-25 17:25 user191 Status closed => feedback
2011-05-25 17:25 user191 Resolution fixed => reopened
2011-05-25 18:53 user21 Note Added: 0000401
2011-05-25 19:32 user191 Note Added: 0000402
2011-05-25 19:32 user191 Status feedback => assigned
2011-05-25 19:47 user191 Note Added: 0000403
2011-05-26 09:29 user21 Note Added: 0000410
2011-05-26 09:29 user21 Status assigned => resolved
2011-05-26 09:29 user21 Resolution reopened => fixed