View Issue Details

IDProjectCategoryView StatusLast Update
0001995OpenFOAM[All Projects] Bugpublic2016-02-14 20:18
ReporterwillAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSOpenSuSEOS VersionLeap 42.1
Product Versiondev 
Fixed in Version 
Summary0001995: fixedMeanFvPatchField doesn't restart
DescriptionfixedMeanFvPatchField isn't restarting in dev. The meanValue Function1 isn't writing its name and type.
Steps To ReproduceFind a case. Set a boundary condition to fixedMean. Decompose it. There will be no "meanValue" entry in the decomposed field files. The case will fail to run in parallel.
Additional InformationThe write method of fixedMeanFvPatchField just needs something like this adding to fix it. There may be some other intended method of achieving this in the new Function1 stuff, but I can't spot it.

os.writeKeyword("meanValue") << meanValue_->type() << token::END_STATEMENT << nl;
TagsNo tags attached.

Activities

henry

2016-02-14 20:18

manager   ~0005941

Thanks for reporting

Resolved by commit 3c185e6d431f9debafe3f6f17dbf6d988d79e6e7

Issue History

Date Modified Username Field Change
2016-02-14 18:17 will New Issue
2016-02-14 20:18 henry Note Added: 0005941
2016-02-14 20:18 henry Status new => resolved
2016-02-14 20:18 henry Resolution open => fixed
2016-02-14 20:18 henry Assigned To => henry