View Issue Details

IDProjectCategoryView StatusLast Update
0001947OpenFOAM[All Projects] Bugpublic2015-12-11 14:22
ReporternsfAssigned Tohenry 
PrioritylowSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSFedoraOS Version23
Product Version 
Fixed in Version 
Summary0001947: foamSequenceVTKFiles chrases due to missing options in basename
DescriptionAt least on fedora 23, CENTOS and ubuntu 14.04 basename doesn't have options -s or -a so the script doesn't work due to line 97:

NAMES=$(basename -s .vtk -a $FILES | sort -u)

On centOS6.2, fedora 23 and ubuntu 14.04 changing line 97 to the following works:

NAMES=$(for f in $FILES; do basename $f .vtk;done | sort -u)



Steps To ReproduceRun foamSequenceVTKFiles on Fedora 23, CENTOS6.2 or Ubuntu 14.04.
Additional InformationWith the above mentioned fix the script works for me. This is probably the last bug I'll report regarding that specific script. =)

I wasn't sure if I should have reported one single bug or the two I have. Since it took you less time to fix the first than it took for me to write the second, perhaps I should have just reported one bug.
TagsNo tags attached.

Activities

henry

2015-12-11 14:22

manager   ~0005735

Resolved in OpenFOAM-3.0.x by commit d8a290b55d283b5fa95f46bcac0aade720053f9a
Resolved in OpenFOAM-dev by commit 71f13ec9dd9f547b09498d31b089eaca192edb06

Issue History

Date Modified Username Field Change
2015-12-11 13:52 nsf New Issue
2015-12-11 14:22 henry Note Added: 0005735
2015-12-11 14:22 henry Status new => resolved
2015-12-11 14:22 henry Resolution open => fixed
2015-12-11 14:22 henry Assigned To => henry