View Issue Details

IDProjectCategoryView StatusLast Update
0001945OpenFOAM[All Projects] Bugpublic2015-12-14 15:08
ReporterpbousquetmAssigned Towyldckat 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOSLinuxOS VersionRead 6.4
Product Version 
Fixed in Version 
Summary0001945: Compilation failure due to dependencies
DescriptionCompilation of OpenFOAM 3.0 ends up with the following message :

make: *** No rule to make target `/soft/OpenFOAM-3.0.0/OpenFOAM-3.0.0/platforms/linux64GccDPInt32Opt/src/OpenFOAM/fields/pointPatchFields/derived/codedFixedValue/codedFixedValuePointPatchFields.C.dep', needed by `/soft/OpenFOAM-3.0.0/OpenFOAM-3.0.0/platforms/linux64GccDPInt32Opt/src/OpenFOAM/fields/pointPatchFields/derived/codedFixedValue/codedFixedValuePointPatchFields.o'. Stop.

I note that the file "/soft/OpenFOAM-3.0.0/OpenFOAM-3.0.0/platforms/linux64GccDPInt32Opt/src/OpenFOAM/fields/pointPatchFields/derived/codedFixedValue/codedFixedValuePointPatchFields.C.dep" is present ; I do not know how to fix this issue.
TagsNo tags attached.

Activities

wyldckat

2015-12-11 11:47

updater   ~0005733

This possibly occurred due to stopping a previous build or due to the lack of space or a flaw in a file sharing mechanism, if "/soft" is shared. One possible fix should be to delete that ".dep" file.

Curiously enough, I reported a more automated fix for this a few days ago: http://www.openfoam.org/mantisbt/view.php?id=1941 - but the final implementation is something I hope to handle this upcoming weekend.

If you have more than one ".dep" file giving you that problem, then download the file "wcleanAllDep" from that task #1941, place the file inside the folder "/soft/OpenFOAM-3.0.0/OpenFOAM-3.0.0/wmake" and then run the following commands:

  foam
  chmod +x wmake/wcleanAllDep
  wcleanAllDep
  wmakeLnIncludeAll

Now you can run "./Allwmake" once again, since "wcleanAllDep" removed all ".dep" files that depend on no longer existing files and "wmakeLnIncludeAll" will create the links that might be missing.

wyldckat

2015-12-13 21:36

updater   ~0005757

@pbousquetm: Please do let us know if this solves the problem you've reported!

henry

2015-12-14 15:07

manager   ~0005761

Based on the patches provided by Bruno: http://www.openfoam.org/mantisbt/view.php?id=1941

I have added the "-update" option to Allwmake in OpenFOAM-dev:

commit 436c3b92e447c5b83c063f852d7656fc8c6efd88

    AllwmakeParseArguments: Added "-update" option
    Updates lnInclude directories and dep files before compilation. This is
    useful to apply following a "git pull" to ensure consistency between the
    source files, dep files and links.

If you run

Allwmake -update

in $WM_PROJECT_DIR it should compile without problems.

If you still have problems due to incomplete files caused for example by a terminated build you may need to build from scratch:

wcleanMachine
Allwmake

Issue History

Date Modified Username Field Change
2015-12-11 11:10 pbousquetm New Issue
2015-12-11 11:47 wyldckat Note Added: 0005733
2015-12-13 21:35 wyldckat Assigned To => wyldckat
2015-12-13 21:35 wyldckat Status new => assigned
2015-12-13 21:36 wyldckat Note Added: 0005757
2015-12-14 15:07 henry Note Added: 0005761
2015-12-14 15:07 henry Status assigned => resolved
2015-12-14 15:07 henry Resolution open => fixed