View Issue Details

IDProjectCategoryView StatusLast Update
0001875OpenFOAM[All Projects] Bugpublic2015-10-25 17:11
ReporterwyldckatAssigned Tohenry 
PrioritylowSeveritytextReproducibilityN/A
Status resolvedResolutionfixed 
Product Versiondev 
Fixed in Version 
Summary0001875: turbulentHeatFluxTemperatureFvPatchScalarField.H doesn't render very well in Doxygen
DescriptionThe example description in "turbulentHeatFluxTemperatureFvPatchScalarField.H" gets squished into a single line by Doxygen: http://foam.sourceforge.net/docs/cpp/a02708.html#details - and in http://openfoam.github.io/Documentation-dev/html/a02627.html#details

Attached is a replacement file for "src/TurbulenceModels/compressible/turbulentFluidThermoModels/derivedFvPatchFields/turbulentHeatFluxTemperature/turbulentHeatFluxTemperatureFvPatchScalarField.H", which is a bit more detailed and which should be better rendered by Doxygen, since it follows the same structure as other header files.
Steps To ReproduceCopy-paste from http://foam.sourceforge.net/docs/cpp/a02708.html#details :


Fixed heat boundary condition to specify temperature gradient. Input heat source either specified in terms of an absolute power [W], or as a flux [W/m2].

Example usage:

hotWall { type compressible::turbulentHeatFluxTemperature; heatSource flux; // power [W]; flux [W/m2] q uniform 10; // heat power or flux kappa fluidThermo; // calculate kappa=alphaEff*thermo.Cp Qr none; // name of the radiative flux value uniform 300; // initial temperature value }

TagsNo tags attached.

Activities

wyldckat

2015-10-21 15:08

updater  

turbulentHeatFluxTemperatureFvPatchScalarField.H (6,670 bytes)

wyldckat

2015-10-21 15:10

updater   ~0005454

Last edited: 2015-10-21 15:11

View 2 revisions

Haven't assigned this report yet, because "temperatureCoupled" could also use some updating, by which I mean that there are a few more missing parameters to be described that affect both classes.

henry

2015-10-25 15:33

manager   ~0005486

Thanks for the update Bruno,
resolved by commit f52fb042b8471121bd6a6bf17e97487b70ae149c

wyldckat

2015-10-25 17:02

updater   ~0005489

Last edited: 2015-10-25 17:05

View 2 revisions

Sorry, but you beat me to it.
I'm reopening and attaching another revision for "turbulentHeatFluxTemperatureFvPatchScalarField.H" (attached file "turbulentHeatFluxTemperatureFvPatchScalarField.H_v2"), as well as an update for "temperatureCoupledBase.H".

Target folders:
  - src/TurbulenceModels/compressible/turbulentFluidThermoModels/derivedFvPatchFields/turbulentHeatFluxTemperature
  - src/TurbulenceModels/compressible/turbulentFluidThermoModels/derivedFvPatchFields/temperatureCoupledBase

wyldckat

2015-10-25 17:03

updater  

temperatureCoupledBase.H (5,090 bytes)

wyldckat

2015-10-25 17:04

updater  

turbulentHeatFluxTemperatureFvPatchScalarField.H_v2 (6,758 bytes)

henry

2015-10-25 17:10

manager   ~0005490

Thanks Bruno.
Resolved by commit 63c620dc68a778dcae7ce7de37a90d817d354f9b

Issue History

Date Modified Username Field Change
2015-10-21 15:08 wyldckat New Issue
2015-10-21 15:08 wyldckat File Added: turbulentHeatFluxTemperatureFvPatchScalarField.H
2015-10-21 15:10 wyldckat Note Added: 0005454
2015-10-21 15:11 wyldckat Note Edited: 0005454 View Revisions
2015-10-25 15:33 henry Note Added: 0005486
2015-10-25 15:33 henry Status new => resolved
2015-10-25 15:33 henry Resolution open => fixed
2015-10-25 15:33 henry Assigned To => henry
2015-10-25 17:02 wyldckat Note Added: 0005489
2015-10-25 17:02 wyldckat Status resolved => feedback
2015-10-25 17:02 wyldckat Resolution fixed => reopened
2015-10-25 17:03 wyldckat File Added: temperatureCoupledBase.H
2015-10-25 17:04 wyldckat File Added: turbulentHeatFluxTemperatureFvPatchScalarField.H_v2
2015-10-25 17:05 wyldckat Note Edited: 0005489 View Revisions
2015-10-25 17:10 henry Note Added: 0005490
2015-10-25 17:10 henry Status feedback => resolved
2015-10-25 17:10 henry Resolution reopened => fixed