View Issue Details

IDProjectCategoryView StatusLast Update
0001780OpenFOAM[All Projects] Bugpublic2015-10-21 13:10
Reporteruser1181Assigned Tohenry 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version12.04
Product Version 
Fixed in Version 
Summary0001780: Problem with fvMeshDistribute when using alphaContactAngle
DescriptionfvMeshDistribute fails to distribute a field if one of the patch fields is of type "alphaContactAngle". It will work, however, if the patch field type is changed to e.g. "zeroGradient" or any other boundary condition I have tested.

In addition I get a warning concerning the mapper if "fixedValue" patches are present.
Steps To ReproduceDownload the attached minimal example, compile the test utility "testRedistribution" and run the "Allrun" script.
Additional InformationThe similar procedure used to work in OF 2.1.1 and is unaffected by the recent bug-fix in the distribute()-function of the refinementHistory.
TagsNo tags attached.

Relationships

related to 0001873 resolvedhenry parallel sync fails 

Activities

user1181

2015-07-09 14:54

 

testRedistribution.tar.gz (110,173 bytes)

user1182

2015-09-09 10:21

  ~0005345

The problem is reproducible on Ubuntu 14.04.
Nobody got any ideas where this is coming from?

henry

2015-09-13 22:15

manager   ~0005358

Resolved in OpenFOAM-2.4.x: commit efc3810d49d1263a5b89411e19ee5b5f9dfbd339

user4

2015-09-30 20:38

 

syncTools.tgz (20,599 bytes)

user4

2015-09-30 20:45

  ~0005379

If you run the fix with -DFULLDEBUG you'll get an out-of-bounds error. Try uploaded code.

Instead of

    comm = worldComm+1

properly allocate the communicator:

    comm = UPstream::allocateCommunicator

with
    parent = worldComm,
    subRanks = list of all processors

and use UPstream::freeCommunicator
to release the communicator.

Issue History

Date Modified Username Field Change
2015-07-09 14:54 user1181 New Issue
2015-07-09 14:54 user1181 File Added: testRedistribution.tar.gz
2015-09-09 10:21 user1182 Note Added: 0005345
2015-09-13 22:15 henry Note Added: 0005358
2015-09-13 22:15 henry Status new => resolved
2015-09-13 22:15 henry Resolution open => fixed
2015-09-13 22:15 henry Assigned To => henry
2015-09-30 20:38 user4 File Added: syncTools.tgz
2015-09-30 20:45 user4 Note Added: 0005379
2015-10-03 15:50 wyldckat Status resolved => feedback
2015-10-03 15:50 wyldckat Resolution fixed => reopened
2015-10-20 10:28 wyldckat Relationship added related to 0001873
2015-10-21 13:09 henry Status feedback => resolved
2015-10-21 13:09 henry Resolution reopened => fixed