View Issue Details

IDProjectCategoryView StatusLast Update
0001718OpenFOAM[All Projects] Bugpublic2015-06-07 08:57
Reporteruser1153Assigned Tohenry 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version14.04
Product Version 
Fixed in Version 
Summary0001718: Can't Install OpenFoam
DescriptionInstallation failed. Here are the messages:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 openfoam240 : Depends: libcgal-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@david-Lenovo-Yoga-2-Pro:/#
Additional InformationInstallation of paraviewopenfoam410 worked though!

Thank you very much!!!
TagsNo tags attached.

Activities

henry

2015-05-29 08:29

manager   ~0004832

I created the Ubuntu packs on 14.04.2 on clean fresh virtual machines and did not see any problems with libcgal-dev. Which patch of 14.04 are you running?

user1153

2015-05-29 16:31

  ~0004838

Thanks Henry. I have 14.04.2 LTS (Long Term Support). Thanks for your help Henry.

henry

2015-05-29 16:33

manager   ~0004839

The openfoam240 pack installs on our 14.04.2 LTS sytems without any problems.

user1153

2015-05-29 16:39

  ~0004840

Hmmm... How about the error message then: "The following packages have unmet dependencies: openfoam240 : Depends: libcgal-dev but it is not going to be installed E: Unable to correct problems, you have held broken packages." What does "held broken packages" mean? Is there a way I can find out what the offensive files are and remove them? Thanks Henry.

henry

2015-05-29 16:40

manager   ~0004841

I do not get this message. Have you tried installing libcgal-dev separately?

user1153

2015-05-29 16:44

  ~0004842

Yes, I did try installing libcgal-dev separately. As I recall, and I will check this when I get back to work (in about an hour), I could not install it. But I did install several similar packages.

user1153

2015-05-29 21:10

 

autoremove_screenDump (21,185 bytes)
root@david-Lenovo-Yoga-2-Pro:/# sudo apt-get autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  freespacenotifier kde-config-pimactivity kde-telepathy-filetransfer-handler
  kde-telepathy-send-file kinfocenter kmenuedit ksysguard libdc1394-22
  libeventviews4 libkmanagesieve4 libksieve4 libksieveui4 libksignalplotter4
  libmessagelist4 libopencv-calib3d2.4 libopencv-core2.4
  libopencv-features2d2.4 libopencv-flann2.4 libopencv-highgui2.4
  libopencv-imgproc2.4 libopencv-legacy2.4 libopencv-ml2.4
  libopencv-objdetect2.4 libopencv-video2.4 libpimactivity4
  libqaccessibilityclient0 libtbb2 linux-headers-3.13.0-32
  linux-headers-3.13.0-32-generic linux-headers-3.13.0-39
  linux-headers-3.13.0-39-generic linux-headers-3.13.0-40
  linux-headers-3.13.0-40-generic linux-headers-3.13.0-44
  linux-headers-3.13.0-44-generic linux-image-3.13.0-32-generic
  linux-image-3.13.0-39-generic linux-image-3.13.0-40-generic
  linux-image-3.13.0-44-generic linux-image-extra-3.13.0-32-generic
  linux-image-extra-3.13.0-39-generic linux-image-extra-3.13.0-40-generic
  linux-image-extra-3.13.0-44-generic linux-signed-image-3.13.0-32-generic
  linux-signed-image-3.13.0-39-generic linux-signed-image-3.13.0-40-generic
  linux-signed-image-3.13.0-44-generic systemsettings
0 upgraded, 0 newly installed, 48 to remove and 0 not upgraded.
After this operation, 1,104 MB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database ... 613371 files and directories currently installed.)
Removing freespacenotifier (4:4.11.11-0ubuntu0.2) ...
Removing kde-config-pimactivity (4:4.13.3-0ubuntu0.1) ...
Removing kde-telepathy-filetransfer-handler (0.8.1-0ubuntu0.1) ...
Removing kde-telepathy-send-file (0.8.1-0ubuntu0.1) ...
Removing kinfocenter (4:4.11.11-0ubuntu0.2) ...
Removing kmenuedit (4:4.11.11-0ubuntu0.2) ...
Removing ksysguard (4:4.11.11-0ubuntu0.2) ...
Removing libopencv-objdetect2.4:amd64 (2.4.8+dfsg1-2ubuntu1) ...
Removing libopencv-legacy2.4:amd64 (2.4.8+dfsg1-2ubuntu1) ...
Removing libopencv-highgui2.4:amd64 (2.4.8+dfsg1-2ubuntu1) ...
Removing libdc1394-22:amd64 (2.2.1-2ubuntu2) ...
Removing libeventviews4 (4:4.13.3-0ubuntu0.1) ...
Removing libksieveui4 (4:4.13.3-0ubuntu0.1) ...
Removing libkmanagesieve4 (4:4.13.3-0ubuntu0.1) ...
Removing libksieve4 (4:4.13.3-0ubuntu0.1) ...
Removing libksignalplotter4 (4:4.11.11-0ubuntu0.2) ...
Removing libmessagelist4 (4:4.13.3-0ubuntu0.1) ...
Removing libopencv-calib3d2.4:amd64 (2.4.8+dfsg1-2ubuntu1) ...
Removing libopencv-video2.4:amd64 (2.4.8+dfsg1-2ubuntu1) ...
Removing libopencv-ml2.4:amd64 (2.4.8+dfsg1-2ubuntu1) ...
Removing libopencv-features2d2.4:amd64 (2.4.8+dfsg1-2ubuntu1) ...
Removing libopencv-flann2.4:amd64 (2.4.8+dfsg1-2ubuntu1) ...
Removing libopencv-imgproc2.4:amd64 (2.4.8+dfsg1-2ubuntu1) ...
Removing libpimactivity4 (4:4.13.3-0ubuntu0.1) ...
Removing libqaccessibilityclient0 (0+git20140203-0ubuntu2) ...
Removing linux-headers-3.13.0-32-generic (3.13.0-32.57) ...
Removing linux-headers-3.13.0-32 (3.13.0-32.57) ...
Removing linux-headers-3.13.0-39-generic (3.13.0-39.66) ...
Removing linux-headers-3.13.0-39 (3.13.0-39.66) ...
Removing linux-headers-3.13.0-40-generic (3.13.0-40.69) ...
Removing linux-headers-3.13.0-40 (3.13.0-40.69) ...
Removing linux-headers-3.13.0-44-generic (3.13.0-44.73) ...
Removing linux-headers-3.13.0-44 (3.13.0-44.73) ...
Removing linux-signed-image-3.13.0-32-generic (3.13.0-32.57) ...
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-3.13.0-53-generic
Found initrd image: /boot/initrd.img-3.13.0-53-generic
Found linux image: /boot/vmlinuz-3.13.0-46-generic
Found initrd image: /boot/initrd.img-3.13.0-46-generic
Found linux image: /boot/vmlinuz-3.13.0-44-generic
Found initrd image: /boot/initrd.img-3.13.0-44-generic
Found linux image: /boot/vmlinuz-3.13.0-40-generic
Found initrd image: /boot/initrd.img-3.13.0-40-generic
Found linux image: /boot/vmlinuz-3.13.0-39-generic
Found initrd image: /boot/initrd.img-3.13.0-39-generic
Found linux image: /boot/vmlinuz-3.13.0-32-generic
Found initrd image: /boot/initrd.img-3.13.0-32-generic
  No volume groups found
Adding boot menu entry for EFI firmware configuration
done
Removing linux-image-extra-3.13.0-32-generic (3.13.0-32.57) ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.13.0-32-generic /boot/vmlinuz-3.13.0-32-generic
update-initramfs: Deleting /boot/initrd.img-3.13.0-32-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.13.0-32-generic /boot/vmlinuz-3.13.0-32-generic
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-3.13.0-53-generic
Found initrd image: /boot/initrd.img-3.13.0-53-generic
Found linux image: /boot/vmlinuz-3.13.0-46-generic
Found initrd image: /boot/initrd.img-3.13.0-46-generic
Found linux image: /boot/vmlinuz-3.13.0-44-generic
Found initrd image: /boot/initrd.img-3.13.0-44-generic
Found linux image: /boot/vmlinuz-3.13.0-40-generic
Found initrd image: /boot/initrd.img-3.13.0-40-generic
Found linux image: /boot/vmlinuz-3.13.0-39-generic
Found initrd image: /boot/initrd.img-3.13.0-39-generic
Found linux image: /boot/vmlinuz-3.13.0-32-generic
  No volume groups found
Adding boot menu entry for EFI firmware configuration
done
Removing linux-image-3.13.0-32-generic (3.13.0-32.57) ...
Examining /etc/kernel/prerm.d.
run-parts: executing /etc/kernel/prerm.d/dkms 3.13.0-32-generic /boot/vmlinuz-3.13.0-32-generic
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.13.0-32-generic /boot/vmlinuz-3.13.0-32-generic
update-initramfs: Deleting /boot/initrd.img-3.13.0-32-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.13.0-32-generic /boot/vmlinuz-3.13.0-32-generic
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-3.13.0-53-generic
Found initrd image: /boot/initrd.img-3.13.0-53-generic
Found linux image: /boot/vmlinuz-3.13.0-46-generic
Found initrd image: /boot/initrd.img-3.13.0-46-generic
Found linux image: /boot/vmlinuz-3.13.0-44-generic
Found initrd image: /boot/initrd.img-3.13.0-44-generic
Found linux image: /boot/vmlinuz-3.13.0-40-generic
Found initrd image: /boot/initrd.img-3.13.0-40-generic
Found linux image: /boot/vmlinuz-3.13.0-39-generic
Found initrd image: /boot/initrd.img-3.13.0-39-generic
  No volume groups found
Adding boot menu entry for EFI firmware configuration
done
Removing linux-signed-image-3.13.0-39-generic (3.13.0-39.66) ...
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-3.13.0-53-generic
Found initrd image: /boot/initrd.img-3.13.0-53-generic
Found linux image: /boot/vmlinuz-3.13.0-46-generic
Found initrd image: /boot/initrd.img-3.13.0-46-generic
Found linux image: /boot/vmlinuz-3.13.0-44-generic
Found initrd image: /boot/initrd.img-3.13.0-44-generic
Found linux image: /boot/vmlinuz-3.13.0-40-generic
Found initrd image: /boot/initrd.img-3.13.0-40-generic
Found linux image: /boot/vmlinuz-3.13.0-39-generic
Found initrd image: /boot/initrd.img-3.13.0-39-generic
  No volume groups found
Adding boot menu entry for EFI firmware configuration
done
Removing linux-image-extra-3.13.0-39-generic (3.13.0-39.66) ...
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.13.0-39-generic /boot/vmlinuz-3.13.0-39-generic
run-parts: executing /etc/kernel/postinst.d/dkms 3.13.0-39-generic /boot/vmlinuz-3.13.0-39-generic
Error! Your kernel headers for kernel 3.13.0-39-generic cannot be found.
Please install the linux-headers-3.13.0-39-generic package,
or use the --kernelsourcedir option to tell DKMS where it's located
Error! Your kernel headers for kernel 3.13.0-39-generic cannot be found.
Please install the linux-headers-3.13.0-39-generic package,
or use the --kernelsourcedir option to tell DKMS where it's located
Error! Your kernel headers for kernel 3.13.0-39-generic cannot be found.
Please install the linux-headers-3.13.0-39-generic package,
or use the --kernelsourcedir option to tell DKMS where it's located
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.13.0-39-generic /boot/vmlinuz-3.13.0-39-generic
update-initramfs: Generating /boot/initrd.img-3.13.0-39-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.13.0-39-generic /boot/vmlinuz-3.13.0-39-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 3.13.0-39-generic /boot/vmlinuz-3.13.0-39-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.13.0-39-generic /boot/vmlinuz-3.13.0-39-generic
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-3.13.0-53-generic
Found initrd image: /boot/initrd.img-3.13.0-53-generic
Found linux image: /boot/vmlinuz-3.13.0-46-generic
Found initrd image: /boot/initrd.img-3.13.0-46-generic
Found linux image: /boot/vmlinuz-3.13.0-44-generic
Found initrd image: /boot/initrd.img-3.13.0-44-generic
Found linux image: /boot/vmlinuz-3.13.0-40-generic
Found initrd image: /boot/initrd.img-3.13.0-40-generic
Found linux image: /boot/vmlinuz-3.13.0-39-generic
Found initrd image: /boot/initrd.img-3.13.0-39-generic
  No volume groups found
Adding boot menu entry for EFI firmware configuration
done
Removing linux-image-3.13.0-39-generic (3.13.0-39.66) ...
Examining /etc/kernel/prerm.d.
run-parts: executing /etc/kernel/prerm.d/dkms 3.13.0-39-generic /boot/vmlinuz-3.13.0-39-generic
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.13.0-39-generic /boot/vmlinuz-3.13.0-39-generic
update-initramfs: Deleting /boot/initrd.img-3.13.0-39-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.13.0-39-generic /boot/vmlinuz-3.13.0-39-generic
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-3.13.0-53-generic
Found initrd image: /boot/initrd.img-3.13.0-53-generic
Found linux image: /boot/vmlinuz-3.13.0-46-generic
Found initrd image: /boot/initrd.img-3.13.0-46-generic
Found linux image: /boot/vmlinuz-3.13.0-44-generic
Found initrd image: /boot/initrd.img-3.13.0-44-generic
Found linux image: /boot/vmlinuz-3.13.0-40-generic
Found initrd image: /boot/initrd.img-3.13.0-40-generic
  No volume groups found
Adding boot menu entry for EFI firmware configuration
done
Removing linux-signed-image-3.13.0-40-generic (3.13.0-40.69) ...
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-3.13.0-53-generic
Found initrd image: /boot/initrd.img-3.13.0-53-generic
Found linux image: /boot/vmlinuz-3.13.0-46-generic
Found initrd image: /boot/initrd.img-3.13.0-46-generic
Found linux image: /boot/vmlinuz-3.13.0-44-generic
Found initrd image: /boot/initrd.img-3.13.0-44-generic
Found linux image: /boot/vmlinuz-3.13.0-40-generic
Found initrd image: /boot/initrd.img-3.13.0-40-generic
  No volume groups found
Adding boot menu entry for EFI firmware configuration
done
Removing linux-image-extra-3.13.0-40-generic (3.13.0-40.69) ...
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.13.0-40-generic /boot/vmlinuz-3.13.0-40-generic
run-parts: executing /etc/kernel/postinst.d/dkms 3.13.0-40-generic /boot/vmlinuz-3.13.0-40-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.13.0-40-generic /boot/vmlinuz-3.13.0-40-generic
update-initramfs: Generating /boot/initrd.img-3.13.0-40-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.13.0-40-generic /boot/vmlinuz-3.13.0-40-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 3.13.0-40-generic /boot/vmlinuz-3.13.0-40-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.13.0-40-generic /boot/vmlinuz-3.13.0-40-generic
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-3.13.0-53-generic
Found initrd image: /boot/initrd.img-3.13.0-53-generic
Found linux image: /boot/vmlinuz-3.13.0-46-generic
Found initrd image: /boot/initrd.img-3.13.0-46-generic
Found linux image: /boot/vmlinuz-3.13.0-44-generic
Found initrd image: /boot/initrd.img-3.13.0-44-generic
Found linux image: /boot/vmlinuz-3.13.0-40-generic
Found initrd image: /boot/initrd.img-3.13.0-40-generic
  No volume groups found
Adding boot menu entry for EFI firmware configuration
done
Removing linux-image-3.13.0-40-generic (3.13.0-40.69) ...
Examining /etc/kernel/prerm.d.
run-parts: executing /etc/kernel/prerm.d/dkms 3.13.0-40-generic /boot/vmlinuz-3.13.0-40-generic
dkms: removing: bbswitch 0.7 (3.13.0-40-generic) (x86_64)

-------- Uninstall Beginning --------
Module:  bbswitch
Version: 0.7
Kernel:  3.13.0-40-generic (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

bbswitch.ko:
 - Uninstallation
   - Deleting from: /lib/modules/3.13.0-40-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall completed.
dkms: removing: nvidia-331-updates 331.113 (3.13.0-40-generic) (x86_64)

-------- Uninstall Beginning --------
Module:  nvidia-331-updates
Version: 331.113
Kernel:  3.13.0-40-generic (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

nvidia_331_updates.ko:
 - Uninstallation
   - Deleting from: /lib/modules/3.13.0-40-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall completed.
dkms: removing: nvidia-331-updates-uvm 331.113 (3.13.0-40-generic) (x86_64)

-------- Uninstall Beginning --------
Module:  nvidia-331-updates-uvm
Version: 331.113
Kernel:  3.13.0-40-generic (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

nvidia-331-updates-uvm.ko:
 - Uninstallation
   - Deleting from: /lib/modules/3.13.0-40-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall completed.
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.13.0-40-generic /boot/vmlinuz-3.13.0-40-generic
update-initramfs: Deleting /boot/initrd.img-3.13.0-40-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.13.0-40-generic /boot/vmlinuz-3.13.0-40-generic
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-3.13.0-53-generic
Found initrd image: /boot/initrd.img-3.13.0-53-generic
Found linux image: /boot/vmlinuz-3.13.0-46-generic
Found initrd image: /boot/initrd.img-3.13.0-46-generic
Found linux image: /boot/vmlinuz-3.13.0-44-generic
Found initrd image: /boot/initrd.img-3.13.0-44-generic
  No volume groups found
Adding boot menu entry for EFI firmware configuration
done
Removing linux-signed-image-3.13.0-44-generic (3.13.0-44.73) ...
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-3.13.0-53-generic
Found initrd image: /boot/initrd.img-3.13.0-53-generic
Found linux image: /boot/vmlinuz-3.13.0-46-generic
Found initrd image: /boot/initrd.img-3.13.0-46-generic
Found linux image: /boot/vmlinuz-3.13.0-44-generic
Found initrd image: /boot/initrd.img-3.13.0-44-generic
  No volume groups found
Adding boot menu entry for EFI firmware configuration
done
Removing linux-image-extra-3.13.0-44-generic (3.13.0-44.73) ...
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.13.0-44-generic /boot/vmlinuz-3.13.0-44-generic
run-parts: executing /etc/kernel/postinst.d/dkms 3.13.0-44-generic /boot/vmlinuz-3.13.0-44-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.13.0-44-generic /boot/vmlinuz-3.13.0-44-generic
update-initramfs: Generating /boot/initrd.img-3.13.0-44-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.13.0-44-generic /boot/vmlinuz-3.13.0-44-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 3.13.0-44-generic /boot/vmlinuz-3.13.0-44-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.13.0-44-generic /boot/vmlinuz-3.13.0-44-generic
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-3.13.0-53-generic
Found initrd image: /boot/initrd.img-3.13.0-53-generic
Found linux image: /boot/vmlinuz-3.13.0-46-generic
Found initrd image: /boot/initrd.img-3.13.0-46-generic
Found linux image: /boot/vmlinuz-3.13.0-44-generic
Found initrd image: /boot/initrd.img-3.13.0-44-generic
  No volume groups found
Adding boot menu entry for EFI firmware configuration
done
Removing linux-image-3.13.0-44-generic (3.13.0-44.73) ...
Examining /etc/kernel/prerm.d.
run-parts: executing /etc/kernel/prerm.d/dkms 3.13.0-44-generic /boot/vmlinuz-3.13.0-44-generic
dkms: removing: bbswitch 0.7 (3.13.0-44-generic) (x86_64)

-------- Uninstall Beginning --------
Module:  bbswitch
Version: 0.7
Kernel:  3.13.0-44-generic (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

bbswitch.ko:
 - Uninstallation
   - Deleting from: /lib/modules/3.13.0-44-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall completed.
dkms: removing: nvidia-331-updates 331.113 (3.13.0-44-generic) (x86_64)

-------- Uninstall Beginning --------
Module:  nvidia-331-updates
Version: 331.113
Kernel:  3.13.0-44-generic (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

nvidia_331_updates.ko:
 - Uninstallation
   - Deleting from: /lib/modules/3.13.0-44-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall completed.
dkms: removing: nvidia-331-updates-uvm 331.113 (3.13.0-44-generic) (x86_64)

-------- Uninstall Beginning --------
Module:  nvidia-331-updates-uvm
Version: 331.113
Kernel:  3.13.0-44-generic (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

nvidia-331-updates-uvm.ko:
 - Uninstallation
   - Deleting from: /lib/modules/3.13.0-44-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall completed.
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.13.0-44-generic /boot/vmlinuz-3.13.0-44-generic
update-initramfs: Deleting /boot/initrd.img-3.13.0-44-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.13.0-44-generic /boot/vmlinuz-3.13.0-44-generic
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-3.13.0-53-generic
Found initrd image: /boot/initrd.img-3.13.0-53-generic
Found linux image: /boot/vmlinuz-3.13.0-46-generic
Found initrd image: /boot/initrd.img-3.13.0-46-generic
  No volume groups found
Adding boot menu entry for EFI firmware configuration
done
Removing systemsettings (4:4.11.11-0ubuntu0.2) ...
Removing libopencv-core2.4:amd64 (2.4.8+dfsg1-2ubuntu1) ...
Removing libtbb2 (4.2~20130725-1.1ubuntu1) ...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.6) ...
root@david-Lenovo-Yoga-2-Pro:/# 
autoremove_screenDump (21,185 bytes)

user1153

2015-05-29 21:25

  ~0004843

Ubuntu Software Center won't let me install libcgal-dev because:

The following packages have unmet dependencies:

libcgal-dev: Depends: libcgal10 (= 4.2-5ubuntu1) but 4.2-5ubuntu1 is to be installed
             Depends: libgmp10-dev but it is a virtual package

I will try to send you the files from trying to install it from Konsole.

user1153

2015-05-29 21:27

 

sudo apt-get update (9,028 bytes)
root@david-Lenovo-Yoga-2-Pro:/# sudo apt-get update
Ign http://us.archive.ubuntu.com trusty InRelease                              
Ign http://security.ubuntu.com trusty-security InRelease                       
Ign http://extras.ubuntu.com trusty InRelease                                  
Ign http://ppa.launchpad.net precise InRelease                                 
Ign http://us.archive.ubuntu.com trusty-updates InRelease                      
Ign http://us.archive.ubuntu.com trusty-backports InRelease                    
Hit http://security.ubuntu.com trusty-security Release.gpg                     
Hit http://extras.ubuntu.com trusty Release.gpg                                
Get:1 http://ppa.launchpad.net precise Release.gpg [316 B]                     
Ign http://www.openfoam.org trusty InRelease                         
Hit http://us.archive.ubuntu.com trusty Release.gpg                  
Hit http://security.ubuntu.com trusty-security Release                         
Hit http://extras.ubuntu.com trusty Release                                    
Get:2 http://us.archive.ubuntu.com trusty-updates Release.gpg [933 B]          
Hit http://ppa.launchpad.net precise Release                         
Ign http://www.openfoam.org trusty Release.gpg                       
Ign http://ppa.launchpad.net precise Release                                   
Hit http://us.archive.ubuntu.com trusty-backports Release.gpg                  
Hit http://extras.ubuntu.com trusty/main Sources                               
Hit http://security.ubuntu.com trusty-security/main Sources                    
Ign http://ppa.launchpad.net precise/main Sources/DiffIndex                    
Ign http://www.openfoam.org trusty Release                                     
Hit http://us.archive.ubuntu.com trusty Release                                
Hit http://extras.ubuntu.com trusty/main amd64 Packages                        
Hit http://security.ubuntu.com trusty-security/restricted Sources              
Ign http://ppa.launchpad.net precise/main amd64 Packages/DiffIndex             
Get:3 http://us.archive.ubuntu.com trusty-updates Release [63.5 kB]            
Ign http://www.openfoam.org trusty/main amd64 Packages/DiffIndex               
Hit http://extras.ubuntu.com trusty/main i386 Packages                         
Hit http://security.ubuntu.com trusty-security/universe Sources                
Ign http://ppa.launchpad.net precise/main i386 Packages/DiffIndex              
Ign http://www.openfoam.org trusty/main i386 Packages/DiffIndex                
Hit http://security.ubuntu.com trusty-security/multiverse Sources              
Hit http://security.ubuntu.com trusty-security/main amd64 Packages             
Hit http://us.archive.ubuntu.com trusty-backports Release                      
Hit http://ppa.launchpad.net precise/main Translation-en                       
Hit http://us.archive.ubuntu.com trusty/main Sources                           
Hit http://security.ubuntu.com trusty-security/restricted amd64 Packages       
Hit http://us.archive.ubuntu.com trusty/restricted Sources                     
Hit http://ppa.launchpad.net precise/main Sources                              
Hit http://us.archive.ubuntu.com trusty/universe Sources                       
Hit http://security.ubuntu.com trusty-security/universe amd64 Packages         
Hit http://ppa.launchpad.net precise/main amd64 Packages                       
Hit http://us.archive.ubuntu.com trusty/multiverse Sources                     
Hit http://security.ubuntu.com trusty-security/multiverse amd64 Packages       
Hit http://ppa.launchpad.net precise/main i386 Packages                        
Hit http://us.archive.ubuntu.com trusty/main amd64 Packages                    
Hit http://security.ubuntu.com trusty-security/main i386 Packages              
Hit http://us.archive.ubuntu.com trusty/restricted amd64 Packages              
Hit http://security.ubuntu.com trusty-security/restricted i386 Packages        
Hit http://us.archive.ubuntu.com trusty/universe amd64 Packages                
Hit http://security.ubuntu.com trusty-security/universe i386 Packages          
Hit http://us.archive.ubuntu.com trusty/multiverse amd64 Packages              
Hit http://security.ubuntu.com trusty-security/multiverse i386 Packages        
Hit http://us.archive.ubuntu.com trusty/main i386 Packages                     
Hit http://us.archive.ubuntu.com trusty/restricted i386 Packages               
Ign http://extras.ubuntu.com trusty/main Translation-en_US                     
Hit http://security.ubuntu.com trusty-security/main Translation-en             
Ign http://ppa.launchpad.net precise/main Translation-en_US                    
Ign http://extras.ubuntu.com trusty/main Translation-en                        
Hit http://security.ubuntu.com trusty-security/multiverse Translation-en
Hit http://us.archive.ubuntu.com trusty/universe i386 Packages                 
Hit http://security.ubuntu.com trusty-security/restricted Translation-en       
Hit http://us.archive.ubuntu.com trusty/multiverse i386 Packages               
Hit http://us.archive.ubuntu.com trusty/main Translation-en                    
Hit http://security.ubuntu.com trusty-security/universe Translation-en
Hit http://us.archive.ubuntu.com trusty/multiverse Translation-en              
Hit http://www.openfoam.org trusty/main amd64 Packages                         
Hit http://us.archive.ubuntu.com trusty/restricted Translation-en              
Hit http://www.openfoam.org trusty/main i386 Packages                          
Hit http://us.archive.ubuntu.com trusty/universe Translation-en                
Get:4 http://us.archive.ubuntu.com trusty-updates/main Sources [206 kB]        
Ign http://www.openfoam.org trusty/main Translation-en_US                      
Ign http://www.openfoam.org trusty/main Translation-en                         
Get:5 http://us.archive.ubuntu.com trusty-updates/restricted Sources [3,433 B] 
Get:6 http://us.archive.ubuntu.com trusty-updates/universe Sources [118 kB]    
Get:7 http://us.archive.ubuntu.com trusty-updates/multiverse Sources [5,152 B] 
Get:8 http://us.archive.ubuntu.com trusty-updates/main amd64 Packages [506 kB] 
Get:9 http://us.archive.ubuntu.com trusty-updates/restricted amd64 Packages [11.8 kB]
Get:10 http://us.archive.ubuntu.com trusty-updates/universe amd64 Packages [279 kB]
Get:11 http://us.archive.ubuntu.com trusty-updates/multiverse amd64 Packages [11.9 kB]
Get:12 http://us.archive.ubuntu.com trusty-updates/main i386 Packages [493 kB] 
Get:13 http://us.archive.ubuntu.com trusty-updates/restricted i386 Packages [11.8 kB]
Get:14 http://us.archive.ubuntu.com trusty-updates/universe i386 Packages [280 kB]
Get:15 http://us.archive.ubuntu.com trusty-updates/multiverse i386 Packages [12.1 kB]
Hit http://us.archive.ubuntu.com trusty-updates/main Translation-en            
Hit http://us.archive.ubuntu.com trusty-updates/multiverse Translation-en      
Hit http://us.archive.ubuntu.com trusty-updates/restricted Translation-en      
Hit http://us.archive.ubuntu.com trusty-updates/universe Translation-en        
Hit http://us.archive.ubuntu.com trusty-backports/main Sources                 
Hit http://us.archive.ubuntu.com trusty-backports/restricted Sources           
Hit http://us.archive.ubuntu.com trusty-backports/universe Sources             
Hit http://us.archive.ubuntu.com trusty-backports/multiverse Sources           
Hit http://us.archive.ubuntu.com trusty-backports/main amd64 Packages          
Hit http://us.archive.ubuntu.com trusty-backports/restricted amd64 Packages    
Hit http://us.archive.ubuntu.com trusty-backports/universe amd64 Packages      
Hit http://us.archive.ubuntu.com trusty-backports/multiverse amd64 Packages    
Hit http://us.archive.ubuntu.com trusty-backports/main i386 Packages           
Hit http://us.archive.ubuntu.com trusty-backports/restricted i386 Packages     
Hit http://us.archive.ubuntu.com trusty-backports/universe i386 Packages       
Hit http://us.archive.ubuntu.com trusty-backports/multiverse i386 Packages     
Hit http://us.archive.ubuntu.com trusty-backports/main Translation-en          
Hit http://us.archive.ubuntu.com trusty-backports/multiverse Translation-en    
Hit http://us.archive.ubuntu.com trusty-backports/restricted Translation-en    
Hit http://us.archive.ubuntu.com trusty-backports/universe Translation-en      
Ign http://us.archive.ubuntu.com trusty/main Translation-en_US                 
Ign http://us.archive.ubuntu.com trusty/multiverse Translation-en_US           
Ign http://us.archive.ubuntu.com trusty/restricted Translation-en_US           
Ign http://us.archive.ubuntu.com trusty/universe Translation-en_US             
Fetched 2,003 kB in 33s (59.5 kB/s)                                            
Reading package lists... Done
W: GPG error: http://ppa.launchpad.net precise Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3C9A6980F827E01E
sudo apt-get update (9,028 bytes)

user1153

2015-05-29 21:28

 

sudo apt-get install libgmp-dev (3,236 bytes)
root@david-Lenovo-Yoga-2-Pro:/#     sudo apt-get install libgmp-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libgmp-dev is already the newest version.
libgmp-dev set to manually installed.
The following packages were automatically installed and are no longer required:
  freespacenotifier kde-config-pimactivity kde-telepathy-filetransfer-handler
  kde-telepathy-send-file kinfocenter kmenuedit ksysguard libdc1394-22
  libeventviews4 libkmanagesieve4 libksieve4 libksieveui4 libksignalplotter4
  libmessagelist4 libopencv-calib3d2.4 libopencv-core2.4
  libopencv-features2d2.4 libopencv-flann2.4 libopencv-highgui2.4
  libopencv-imgproc2.4 libopencv-legacy2.4 libopencv-ml2.4
  libopencv-objdetect2.4 libopencv-video2.4 libpimactivity4
  libqaccessibilityclient0 libtbb2 linux-headers-3.13.0-32
  linux-headers-3.13.0-32-generic linux-headers-3.13.0-39
  linux-headers-3.13.0-39-generic linux-headers-3.13.0-40
  linux-headers-3.13.0-40-generic linux-headers-3.13.0-44
  linux-headers-3.13.0-44-generic linux-image-3.13.0-32-generic
  linux-image-3.13.0-39-generic linux-image-3.13.0-40-generic
  linux-image-3.13.0-44-generic linux-image-extra-3.13.0-32-generic
  linux-image-extra-3.13.0-39-generic linux-image-extra-3.13.0-40-generic
  linux-image-extra-3.13.0-44-generic linux-signed-image-3.13.0-32-generic
  linux-signed-image-3.13.0-39-generic linux-signed-image-3.13.0-40-generic
  linux-signed-image-3.13.0-44-generic systemsettings
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@david-Lenovo-Yoga-2-Pro:/# 
root@david-Lenovo-Yoga-2-Pro:/# sudo apt-get install libmpfr-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libmpfr-dev is already the newest version.
libmpfr-dev set to manually installed.
The following packages were automatically installed and are no longer required:
  freespacenotifier kde-config-pimactivity kde-telepathy-filetransfer-handler
  kde-telepathy-send-file kinfocenter kmenuedit ksysguard libdc1394-22
  libeventviews4 libkmanagesieve4 libksieve4 libksieveui4 libksignalplotter4
  libmessagelist4 libopencv-calib3d2.4 libopencv-core2.4
  libopencv-features2d2.4 libopencv-flann2.4 libopencv-highgui2.4
  libopencv-imgproc2.4 libopencv-legacy2.4 libopencv-ml2.4
  libopencv-objdetect2.4 libopencv-video2.4 libpimactivity4
  libqaccessibilityclient0 libtbb2 linux-headers-3.13.0-32
  linux-headers-3.13.0-32-generic linux-headers-3.13.0-39
  linux-headers-3.13.0-39-generic linux-headers-3.13.0-40
  linux-headers-3.13.0-40-generic linux-headers-3.13.0-44
  linux-headers-3.13.0-44-generic linux-image-3.13.0-32-generic
  linux-image-3.13.0-39-generic linux-image-3.13.0-40-generic
  linux-image-3.13.0-44-generic linux-image-extra-3.13.0-32-generic
  linux-image-extra-3.13.0-39-generic linux-image-extra-3.13.0-40-generic
  linux-image-extra-3.13.0-44-generic linux-signed-image-3.13.0-32-generic
  linux-signed-image-3.13.0-39-generic linux-signed-image-3.13.0-40-generic
  linux-signed-image-3.13.0-44-generic systemsettings
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

wyldckat

2015-05-29 23:53

updater   ~0004846

@RichlandDavid: It seems that you have a stray repository among the list of repositories for apt-get to use. Namely this one:

  http://ppa.launchpad.net precise

Try to find within this folder for this stray repository and remove the respective entry: /etc/apt/sources.list.d/

And/or check within the file "/etc/apt/sources.list".

After removing that repository from the valid list, hopefully it will solve the problem.

user1153

2015-05-30 02:50

  ~0004848

OK thank you I did this to the file sources.list:

## deb http://ppa.launchpad.net/plt/racket/ubuntu precise main
## deb-src http://ppa.launchpad.net/plt/racket/ubuntu precise main

user1153

2015-05-30 02:55

  ~0004849

OK, still no luck with installing libboost-all-dev.

root@david-Lenovo-Yoga-2-Pro:/# apt-get install libboost-all-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libboost-all-dev : Depends: libboost-dev but it is not going to be installed
                    Depends: libboost-tools-dev
                    Depends: libboost-atomic-dev but it is not going to be installed
                    Depends: libboost-chrono-dev but it is not going to be installed
                    Depends: libboost-context-dev but it is not going to be installed
                    Depends: libboost-coroutine-dev but it is not going to be installed
                    Depends: libboost-date-time-dev but it is not going to be installed
                    Depends: libboost-exception-dev but it is not going to be installed
                    Depends: libboost-filesystem-dev but it is not going to be installed
                    Depends: libboost-graph-dev but it is not going to be installed
                    Depends: libboost-graph-parallel-dev but it is not going to be installed
                    Depends: libboost-iostreams-dev but it is not going to be installed
                    Depends: libboost-locale-dev but it is not going to be installed
                    Depends: libboost-log-dev but it is not going to be installed
                    Depends: libboost-math-dev but it is not going to be installed
                    Depends: libboost-mpi-dev but it is not going to be installed
                    Depends: libboost-mpi-python-dev but it is not going to be installed
                    Depends: libboost-program-options-dev but it is not going to be installed
                    Depends: libboost-python-dev but it is not going to be installed
                    Depends: libboost-random-dev but it is not going to be installed
                    Depends: libboost-regex-dev but it is not going to be installed
                    Depends: libboost-serialization-dev but it is not going to be installed
                    Depends: libboost-signals-dev but it is not going to be installed
                    Depends: libboost-system-dev but it is not going to be installed
                    Depends: libboost-test-dev but it is not going to be installed
                    Depends: libboost-thread-dev but it is not going to be installed
                    Depends: libboost-timer-dev but it is not going to be installed
                    Depends: libboost-wave-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@david-Lenovo-Yoga-2-Pro:/#

wyldckat

2015-05-31 23:39

updater   ~0004860

@RichlandDavid: I don't understand why you're trying to install "libboost-all-dev", since the "openfoam240" deb package doesn't seem to depend on it and neither do the "install from source" instructions have this requirement.

At most, you would only need "libboost-system-dev libboost-thread-dev".

Nonetheless, it feels like there is something contaminating your installation. Perhaps you used other repositories that installed another "libboost" set of packages, which are now incompatible with the standard ones from Ubuntu's own repositories?

user1153

2015-06-01 14:18

  ~0004862

Thanks wyldckat. What about the following message I've been getting then?

"The following packages have unmet dependencies: openfoam240 : Depends: libcgal-dev but it is not going to be installed E: Unable to correct problems, you have held broken packages."

Some sort of "contamination" is happening all right. But this happened on the very first installation attempt. I got the openfoam240 from the official website. And the paraview program loaded fine. Any thoughts then? Thanks again wyldckat.

wyldckat

2015-06-01 14:26

updater   ~0004863

@RichlandDavid: Mmm... this reminded me of a bug that was reported sometime ago regarding Ubuntu 14.04.2.
I've checked the forum just now and on this thread: http://www.cfd-online.com/Forums/openfoam-installation/151937-solved-some-packages-could-not-installed-openfoam-2-3-1-ubuntu-14-04-lts.html - is reported the same exact error with "libcgal-dev".
The forum member who created that thread also updated the post indicating that the instructions given here: http://www.upubuntu.com/2013/05/how-to-fix-broken-packages-using.html - would fix the problem with the broken packages.

user1153

2015-06-01 22:04

  ~0004868

Did the recommended fixes from prior note this morning. Tried loading openfoam240 again. Got the message: E: Unable to locate package openfoam240.

So here is what I've done. Down-loaded the code into /opt/opennfoam240.
root@david-Lenovo-Yoga-2-Pro:/opt/openfoam240# ls -l
total 80
-rwxrwxr-x 1 david david 932 May 22 02:50 Allwmake
drwxrwxr-x 5 david david 4096 May 22 02:50 applications
drwxrwxr-x 3 david david 4096 May 22 02:50 bin
-rw-rw-r-- 1 david david 35647 May 22 02:50 COPYING
drwxrwxr-x 6 david david 4096 May 22 02:50 doc
drwxrwxr-x 7 david david 4096 May 22 02:50 etc
-rw-rw-r-- 1 david david 7656 May 22 02:50 README.html
-rw-rw-r-- 1 david david 1471 May 22 02:50 README.org
drwxrwxr-x 37 david david 4096 May 22 02:50 src
drwxrwxr-x 16 david david 4096 May 22 02:50 tutorials
drwxrwxr-x 5 david david 4096 May 22 02:50 wmake


When I try to run ./Allwmake, this happens:

root@david-Lenovo-Yoga-2-Pro:/opt/openfoam240# ./Allwmake
./Allwmake: 4: ./Allwmake: wmakeCheckPwd: not found
Error: Current directory is not $WM_PROJECT_DIR
    The environment variables are inconsistent with the installation.
    Check the OpenFOAM entries in your dot-files and source them.
root@david-Lenovo-Yoga-2-Pro:/opt/openfoam240#

Any thoughts? Thanks wyldckat.

wyldckat

2015-06-01 22:19

updater   ~0004870

@RichlandDavid:
Don't place the source code in the folder "/opt", if you're not familiar enough with using Linux.
If you want to build from source code, follow the instructions to the letter, so that you have the highest likelihood of success.


As for the message:
  E: Unable to locate package openfoam240.

it means that you need to follow the installation instructions from the start, because the repository file "/etc/apt/sources.list.d/openfoam.list" was removed.

user1153

2015-06-02 02:03

  ~0004871

Thanks wyldckat but I did follow the installation instructions from the start again. Also, the installation instructions note that now the openfoam240 is installed in the/opt directory. This is in fact the case, because that is where the successful istallation of paraviewopenfoam410 resides. This is what happens with the installation:

root@david-Lenovo-Yoga-2-Pro:/# sudo apt-get install openfoam240
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 openfoam240 : Depends: libcgal-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I can't install libcgal-dev; this is what happens:

root@david-Lenovo-Yoga-2-Pro:/# sudo apt-get install libcgal-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libcgal-dev : Depends: libboost-dev but it is not going to be installed
               Depends: libboost-thread-dev but it is not going to be installed
               Depends: libboost-system-dev but it is not going to be installed
               Depends: libboost-program-options-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

And I can't install the libboost programs because it notes that it needs version 1.54 of them. What I have installed are the more recent version 1.55 of all the required programs. Shall I delete these and install the version 1.54s? Thanks wyldckat.

wyldckat

2015-06-06 15:05

updater   ~0004891

@RichlandDavid:
Since you didn't give a clear indication of how you installed Boost 1.55, I ended up not trying to answer any sooner (didn't have much time either), since I would have to try and figure out how you tried to install that version.

Anyway, the issue seems very simple:

 1- The deb packages of OpenFOAM 2.4.0 were created with a standard Ubuntu installation.

 2- Your Ubuntu installation has non-standard packages, which are tampering with the possibility of installing the OpenFOAM 2.4.0 deb package.

 3- You will have to choose either one of the following possibilities:

  a- Revert to a standard installation of Ubuntu. So far, from what you've found out, it seems that the only non-standard detail is Boost 1.55. If you fix that and any other non-standard packages, the problem should be solved.

  b- To stop trying to install the deb package of OpenFOAM and instead install from source code. Although again, you probably will have problems installing the packages you need for building from source code, given the conflicts apt-get is telling you about.

Either way, from what I can figure out and remember, most of the problems you're reporting have nothing to do with problems in OpenFOAM itself.
It seems to be a problem of how you've configured your Ubuntu installation, which is beyond the scope of this bug tracker at OpenFOAM.org. Ubuntu has dedicated forums and bug trackers for their own issues ;)

By the way, if you do build from source code, OpenFOAM's "ThirdParty-2.4.0" folder has its own CGAL source code package, which I believe it will be built independently of whether you have a system-wide CGAL installation or not.

user1153

2015-06-07 01:22

  ~0004893

Thanks wyldckat we are on the same page, both with respect to time crunch and procedure. I successfully installed OpenFOAM. First I made my Ubuntu packages standard, particularly the offending ones. Thanks again wyldckat.

Issue History

Date Modified Username Field Change
2015-05-29 03:18 user1153 New Issue
2015-05-29 08:29 henry Note Added: 0004832
2015-05-29 16:31 user1153 Note Added: 0004838
2015-05-29 16:33 henry Note Added: 0004839
2015-05-29 16:39 user1153 Note Added: 0004840
2015-05-29 16:40 henry Note Added: 0004841
2015-05-29 16:44 user1153 Note Added: 0004842
2015-05-29 21:10 user1153 File Added: autoremove_screenDump
2015-05-29 21:25 user1153 Note Added: 0004843
2015-05-29 21:27 user1153 File Added: sudo apt-get update
2015-05-29 21:28 user1153 File Added: sudo apt-get install libgmp-dev
2015-05-29 23:53 wyldckat Note Added: 0004846
2015-05-30 02:50 user1153 Note Added: 0004848
2015-05-30 02:55 user1153 Note Added: 0004849
2015-05-31 23:39 wyldckat Note Added: 0004860
2015-06-01 14:18 user1153 Note Added: 0004862
2015-06-01 14:26 wyldckat Note Added: 0004863
2015-06-01 22:04 user1153 Note Added: 0004868
2015-06-01 22:19 wyldckat Note Added: 0004870
2015-06-02 02:03 user1153 Note Added: 0004871
2015-06-06 15:05 wyldckat Note Added: 0004891
2015-06-07 01:22 user1153 Note Added: 0004893
2015-06-07 08:56 henry Status new => resolved
2015-06-07 08:56 henry Resolution open => fixed
2015-06-07 08:56 henry Assigned To => henry