View Issue Details

IDProjectCategoryView StatusLast Update
0001705OpenFOAM[All Projects] Bugpublic2015-05-26 22:51
ReporterwyldckatAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0001705: Upgrade on the versions for CGAL, Open-MPI and Scotch done in 2.3.x, partially break its build
DescriptionBefore I forget: the ThirdParty-2.4.x repository isn't up yet, at least not publicly.


By upgrading the versions for CGAL, Open-MPI and Scotch directly in 2.3.x, it will partially break the builds for people that are still using 2.3.x.

Although an upgrade path can be set-up/written, based on the current 2.3.x and 2.4.x repositories, it would be helpful that 2.3.x is kept operational as a standalone, without having to forcefully upgrade to 2.4.x or download individual 3rd party packages or manually revert the commits regarding the versions.

Therefore, since 2.4.x has been released, this report is for requesting that the commits related to these 3rd party version upgrades in OpenFOAM-2.3.x and ThirdParty-2.3.x be reverted.

If I'm not mistaken, the following commands should safely revert these version upgrades on 2.3.x:

  foam
  git revert --no-edit 3bd206da9
  git revert --no-edit a253ceb33
  git revert --no-edit f51182721
  git revert --no-edit b9acd12c2

  foam3rdParty
  git revert --no-edit d7367e885a03


TagsNo tags attached.

Activities

henry

2015-05-24 13:46

manager   ~0004788

Personally I would prefer to be using the more recent versions of CGAL, OpenMPI and Scotch in OpenFOAM-2.3.x but I can do that locally if everyone else would prefer to stick with older versions.

If others would also like these packages to be downgraded as Bruno requests please comment here and if this is the general view I will revert the commits.

henry

2015-05-24 14:03

manager   ~0004789

> ThirdParty-2.4.x repository isn't up yet, at least not publicly.

It is now

GRAUPS

2015-05-26 21:59

reporter   ~0004814

I agree with henry in the sense that I like the updated packages, but I agree with bruno in that it broke everyone's thirdparty compilations for 2.3.x after a git pull. I think it's important to maintain a consistent set of compile instructions. The compile instructions for openfoam 2.3.x are no longer valid because it has you download the "official" released thirdparty package (2.3.1) from sourceforge and rename it to compile with the git releases. This no longer works with 2.3.x because the thirdparty 2.3.1 package doesn't contain the updated versions of CGAL etc for OpenFOAM 2.3.x.

My vote is to either revert the git commits or to update the compile instructions located here...

http://www.openfoam.org/archive/2.3.1/download/git.php

henry

2015-05-26 22:51

manager   ~0004815

I have reverted the CGAL and OpenMPI versions as requested.

Issue History

Date Modified Username Field Change
2015-05-24 13:35 wyldckat New Issue
2015-05-24 13:46 henry Note Added: 0004788
2015-05-24 14:03 henry Note Added: 0004789
2015-05-26 21:59 GRAUPS Note Added: 0004814
2015-05-26 22:51 henry Note Added: 0004815
2015-05-26 22:51 henry Status new => resolved
2015-05-26 22:51 henry Resolution open => fixed
2015-05-26 22:51 henry Assigned To => henry