View Issue Details

IDProjectCategoryView StatusLast Update
0001687OpenFOAM[All Projects] Bugpublic2015-05-24 18:59
ReporterTimm SeverinAssigned Tohenry 
PrioritylowSeveritytextReproducibilityN/A
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version13.10
Product Version 
Fixed in Version 
Summary0001687: Wrong class description
DescriptionIn the files (all descriptions based on radiationCoupledBase.H):

$FOAM_SRC/thermophysicalModels/radiationModels/derivedFvPatchFields/radiationCoupledBase/radiationCoupledBase.H
$FOAM_SRC/thermophysicalModels/radiationModels/derivedFvPatchFields/greyDiffusiveRadiation/greyDiffusiveRadiationMixedFvPatchScalarField.H
$FOAM_SRC/thermophysicalModels/radiationModels/derivedFvPatchFields/greyDiffusiveRadiation/greyDiffusiveViewFactorFixedValueFvPatchScalarField.H

Description in header is wrong:

The options for the emissivity are "lookup" and "solidRadiation", not solidThermo.

Furthermore I think the descriptions are misleading, since (as far as I read the code) "lookup" does not read a volScalarField as such, but rather the value stored in the same dictionary under emissivity, i.e. a constant value (as in the example dictionaries shown).
And the solidRadiation options seems to use the emissivity values obtained at a different, mapped boundary condition. The description "use solidThermo emissivity" does not really clarify that.
TagsNo tags attached.

Activities

henry

2015-05-24 18:59

manager   ~0004790

Thanks for the bug-report. I have corrected the documentation in OpenFOAM-2.4.x and OpenFOAM-dev, I hope it makes more sense now. If not please provide any additional description you would like added.

commit 909575ce072373948cc8d19f4325aa01dc14167a

Issue History

Date Modified Username Field Change
2015-05-08 14:54 Timm Severin New Issue
2015-05-24 18:59 henry Note Added: 0004790
2015-05-24 18:59 henry Status new => resolved
2015-05-24 18:59 henry Resolution open => fixed
2015-05-24 18:59 henry Assigned To => henry