View Issue Details

IDProjectCategoryView StatusLast Update
0001641OpenFOAM[All Projects] Bugpublic2015-04-18 11:37
Reporteruser1116Assigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSRHELOS Version6.6
Product Version 
Fixed in Version 
Summary0001641: Constant time cannot be singularly reconstructed
DescriptionThough the help documentation for reconstructPar and reconstructParMesh says that -constant will _add_ the constant time to the list of timesteps to be reconstructed, that seems to only be the case if no list of times are provided. For example, the following will result in only timestep 0.02 being reconstructed:

reconstructParMesh -constant -time 0.02

One might expect that both constant _and_ 0.02 would be reconstructed. Additionally, the following does not work to singularly reconstruct only the constant time:

reconstructParMesh -time constant

It's common at this point to reconstruct several timesteps simultaneously in order to speed up the reconstruction (which for very large cases can take many hours when run serially, and potentially consume a very large amount of memory), however if one wants to reconstruct constant, serial reconstruction is currently the only option

I request that explicit reconstruction of constant be supported such that only constant is reconstructed and/or the specification of both -constant and -time result in the reconstruction of constant and all of the specified timesteps.
Steps To ReproducereconstructParMesh -constant -time 0.02
reconstructPar -constant -time -0.02

Note that only the specified timestep is reconstructed and constant is not.
TagsreconstructPar, reconstructParMesh

Activities

henry

2015-04-11 13:16

manager   ~0004604

I am unable to reproduce the issue you have raised in OpenFOAM-2.3.x or -dev. When I run reconstructPar on the cavity case the -constant option operates exactly as expected so

reconstructPar -constant -time 0.2

reconstructs the constant and 0.2 directories and

reconstructPar -constant

reconstructs the constant directory only.


Could you please provide step-by-step instructions on how to reproduce the problem you see?

user1116

2015-04-14 23:26

  ~0004611

I build 2.3.x today and I still have the same problem. As a test, I am using the damBreakWithObstacle case from $FOAM_TUTORIAL/multiphase/interDyMFoam/ras.

I deconstruct the case for 32 processes, modifying system/deconstructPar as such:

numberOfSubdomains 32;
.
.
.
simpleCoeffs
{
    n ( 4 4 2 );
    delta 0.001;
}

hierarchicalCoeffs
{
    n ( 4 4 2 );
    delta 0.001;
    order xyz;
}

I copy time 0.org to 0.

I then run: blockMesh; topoSet; subsetMesh -overwrite c0 -patch walls; checkMesh; setFields; decomposePar

I then run the case on 32 processes:

mpirun -np 32 interDyMFoam -parallel

Once the simulation has completed, I attempt reconstruction for constant and a single timestep like so:

reconstructParMesh -mergeTol 1e-06 -constant -time 0.02

The only time I see being reconstructed is 'time = 0.02'.

However, if I run this:

reconstructParMesh -mergeTol 1e-06 -constant

all timesteps and constant are reconstructed, and I see several lines with respect to reconstruction of 'time = constant', along with the reconstruction of every timestep in the simulation.

Hopefully this is more clear. I can certainly send a lot more data, including the complete output of both reconstructParMesh commands I showed above.

user1116

2015-04-14 23:37

 

constant-0.02.out.gz (2,172 bytes)

user1116

2015-04-14 23:37

 

constant-all.out.gz (71,781 bytes)

user1116

2015-04-14 23:38

  ~0004612

I've uploaded the output from the reconstructParMesh commands I mentioned. Both have the command I used to generate them on the first line.

Thanks much for looking into the issue.

henry

2015-04-17 15:18

manager   ~0004616

You indicate that the problem exists with reconstructParMesh and reconstructPar, I am unable to reproduce the problem with reconstructPar could you check this?

henry

2015-04-18 11:37

manager   ~0004621

I am unable to reproduce this issue in reconstructPar, in fact I have fixed reconstructParMesh using code from reconstructPar. If you are able to reproduce the problem in reconstructPar please reopen with details of how to reproduce.

Resolved by commit 8e6264ed2de2544c723cd894d49f0fc967e55e57

Issue History

Date Modified Username Field Change
2015-04-02 00:59 user1116 New Issue
2015-04-11 13:16 henry Note Added: 0004604
2015-04-14 23:26 user1116 Note Added: 0004611
2015-04-14 23:37 user1116 File Added: constant-0.02.out.gz
2015-04-14 23:37 user1116 File Added: constant-all.out.gz
2015-04-14 23:38 user1116 Note Added: 0004612
2015-04-15 00:13 user1116 Tag Attached: reconstructPar
2015-04-15 00:13 user1116 Tag Attached: reconstructParMesh
2015-04-17 15:18 henry Note Added: 0004616
2015-04-18 11:37 henry Note Added: 0004621
2015-04-18 11:37 henry Status new => resolved
2015-04-18 11:37 henry Resolution open => fixed
2015-04-18 11:37 henry Assigned To => henry